._default.items (dot underscore) files when editing

Hello i have setup OH2 following the instructions and also setup the samba share. I mapped the config folder to my Macbook. all fine.
If i open a file like default.items or home.rules, edit it and save it. i got two files:
._default.items and a default.items
Both will be loaded form OH2 (i see in the log)

2017-03-03 14:02:17.054 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'alexa.items’
2017-03-03 14:02:17.408 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model '._alexa.items’
2017-03-03 14:02:17.558 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model '._alexa.items’
2017-03-03 14:02:17.604 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model 'alexa.items’
2017-03-03 14:02:17.640 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model '._alexa.items’
2017-03-03 14:02:17.658 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model ‘._alexa.items’

This is also the case when i just copy a local file to the mapped configuration folder via the Mac OSX Finder

how to avoid the creation of the files beginning with ._ ?

Thanks a lot

Why didn’t you ask google about that? http://lmgtfy.com/?q=dot+underscore+macosx

I’m not sure how to tame your Mac. This might be the easiest solution on server side: https://www.lavalite.de/2008/10/12/disable-creation-of-_files-dot-underscore-files - also see the comments here: http://apple.stackexchange.com/a/182601

Thankfully I do not own a Mac, you will need to test this yourself.

1 Like

Did anyone else ever encounter that problem? Sounds like something that would happen to every Mac user…
If that’s the case, we might need to add these veto rules to the Samba setup recommendations.

Many Thanks ThomDietrich, i will check it tonight.

Okay resolved Thanks


With your tipp: veto files = /._*/.DS_Store/
many thanks

This might not be interesting to you but to whoever is reading this: the veto file setting is now part of the openHABian configuration.

1 Like

perfect thanks for the info.