010101 Popp Wireless Thermostatic Valve TRV

It seems I can not change the SETPOINT on this: 010101 Popp Wireless Thermostatic Valve TRV

[EDIT:Corrected the URL]

Using todays snapshot.
Any suggestion what to try?

Also it is giving me th eerrorcode E5 on the display - it means “The termostat is not receiving the expected replies form the control system. Check tat you have a Z-wave certified controller rnning and it has the necessary functionality to control the thermostat”. Can I change the XML-file somehow?

Maybe it’s not included into the network properly, or is out of range of the controller? You could try getting a debug log to see what communications is going on between the OH and the device (although I suspect none based on the error).

It shows the temperature and battery level. But can not select set temperature

I would suggest getting a debug log to see what communications is going on between the OH and the device…

Did you ever get this working? I was looking at this model …

No, it still gives E5. Havent had time to debug yet. Will try to do it now. I have another Z-wave right next to it working fine, so should not be an issue with distance to the unit.

After doing an update it seems it now correctly reports only Sensor heating, temperature and Battery level and clock offsett. Only those 4 channels. However I still can not set the setpoint_heating.

With my Danfoss thermostat I had almost the same problem, after setting (or slightly changing) the wakeup period it works fine.

BTW, looking at the database it is not there at all and trying your link to the database above it looks very messy:

Maybe it’s better to ping @chris for that problem …

It works now - I can set the heatpoint! Not sure what did it - but anyway.

Hmmm - what exactly are you looking at?

If I look at this device (or what I think the device is that we’re talking about) then I don’t see any of the mess that you have in your image -:


I had an error on my initial URL pointing to …/4495 instead of the correct /449 - I updated the original post with the URL.

Two problems at the same time: I looked under manufacturer POPP and the device is under Danfoss and then the wrong link in the post … everything is fine now.

Edit: when accidentally putting a four digit number at the end of any link it gives that messy output :heart_eyes:

Yes - I’ve now fixed this. If the device didn’t exist, then it still tried to print the page, but it just printed errors… It now just prints a clear “incorrect URL” error…

Can you remember something you have done? I have the same issue with this Popp Tmermostatic Valve, after a while getting E5. When waking it up manually by pushing the middle button, I’m able to change setpoint and receive the temperature, but after a while getting E5 in display and can not change the setpoint. Seems to be a weakup thing. I tried to exclude it and include it with Zwave.Me instead of Habmin, but same result.
Would appreciate any hints.