#1534 --- Failed installing 'openhab-misc-restdocs'

Tags: #<Tag:0x00007f387356fdf8>

The REST Docs are now a UI. So if you install it through addons.cfg, it needs to be added to “ui” instead of “misc” now.

If the error keeps showing you may also need to update this in:

userdata/config/org/openhab/addons.config

3 Likes

Thanks for the feedback.
Like what i did since 2.3, i do not touch addons.config and by now after updating all UIs from before the update are available afterwards…

I installed manually via paperUI the following UI “ui-restdocs - 2.5.0.SNAPSHOT” - but still after a day and several reboots the error message is still arround…once per minute from what i have seen.

Any idea?
So this change @API is new coming in somewhere after #1512?

see your other post, snapshots are currently broken

To expand on @wborn’s reply, if you want the restdocs UI installed via addons.cfg, remove the restdocs entry from the misc section and add it to the ui section of addons.cfg.

I am running OH 2.5.0 SNAPSHOT s1534 here and the restdocs are installed and working correctly on that system. The misc and ui entries from my addons.cfg file are:

# A comma-separated list of miscellaneous services to install (e.g. "misc = myopenhab")
misc = ruleengine
...
# A comma-separated list of UIs to install (e.g. "ui = basic,paper")
ui = basic,habmin,paper,restdocs

[Added for clarification]
I’m referring to text configuration of addons in ${OPENHAB_CONFIG}/services/addons.cfg.

Note that the file I’m referring to (userdata/config/org/openhab/addons.config) is the file which is also used for storing the installed add-ons when adding them using Paper UI.

It’s a different file you’d use when installing add-ons using textual configuration (which is services/addons.cfg). Unfortunately there is currently no way to automatically patch it when there are such add-on changes.

I think with build 1534 the snapshots are usable again. Do you have an example of what is still broken?

Sorry, no I don’t; was just going from other posts of knowledgeable people and waiting to hear otherwise. Glad to hear that things are OK again with 1534…

Hello - one observation concerning snapshot #1534. I upgraded and everything runs fine - except, that I get now this logentry:

2019-02-24 20:47:36.232 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-mqtt1’

Though I havent installed the mqtt binding (and never tried - afaik)

my ( /srv/openhab2-userdata/config/org/openhab/addons.config ) looks like this:

:org.apache.felix.configadmin.revision:=L"2"
action=“mail”
binding=“ntp,exec,mqtt1,weatherunderground,zwave,http1,owserver1,hue,astro,expire1,nibeuplink”
felix.fileinstall.filename=“file:/var/lib/openhab2/etc/org.openhab.addons.cfg”
legacy=B"false"
misc=“openhabcloud,market”
package=“standard”
persistence=“influxdb”
remote=B"true"
service.pid=“org.openhab.addons”
transformation=“jsonpath,map,regex,exec,xslt”
ui=“basic,paper,habpanel,habmin”

Do you have an idea how to get rid of this?
I looked into the karaf console and couldn’t see anything, which hints at mqtt.
Thank you very much!

Just remove mqtt1, from this line. :slight_smile:

1 Like

Reading is a gift, which not everyone has :wink:
Thanks !

1 Like

I’m getting the same errors with build 1557. I’ve installed the rest docs adding via Paper UI and it says it’s installed.

My addons.config is empty beneath the UI comment. Can I simply add ui = restdocs (No quotes) and that fill fix the problem?

also have the same issue now with #1558.
Does the error message mean that there is a link to something that does not exist anymore…restdocs not being whatever it was before becoming an UI?

hm, my addons.conf in /var/lib/openhab2/config/org/openhab (not sure if this path is the one to blame)…
i see the following:

:org.apache.felix.configadmin.revision:=L"7"

action=“mail,pushover”
binding=“http1,mqtt1,ntp,systeminfo,weather1,zwave,jeelink,astro,weatherunderground,expire1”
legacy=B"true"
misc=“restdocs”
package=“expert”
persistence=",rrd4j"
remote=B"true"
service.pid=“org.openhab.addons”
transformation=“map,regex,xslt,exec,javascript,scale,xpath,jsonpath”
ui=“classic,basic,paper,habpanel,habmin”

So there is misc=restdocs…is this outdated? i normally do only add/remove via PaperUI.
Do i have to remove it manually via commandline?..if i want the docs again, i can reinstall them in UI from PaperUI?

Thanks
Norbert

Yes just remove the line:

from that addons.config file.

Then restart openHAB and install the REST Docs via Paper UI, Add-ons, User Interfaces:

1 Like

Hi, i did what you proposed…mostly. i let misc="" arround but that should not have any impact i guess…

but now i see the following error log in openhab.log

2019-03-23 21:47:49.681 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-ui-restdocs’: Error restarting bundles:
Exception in org.eclipse.smarthome.io.rest.sse.internal.SseActivator.start() of bundle org.openhab.core.io.rest.sse.

ah found the following…again in the snapshot jungle…why didn’t keep calm and stay with #1512 uaaaahhhhhhhh

It’s a known issue. Just restart openHAB and the exception should be gone:

Yesterday I installed 2.5.0-Snapshot with openhabian.config

Since then a have several problem one of them is, that I geht this message several times per minute:

2019-04-01 09:49:28.805 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007

2019-04-01 09:49:28.831 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-misc-restdocs'

This two messages rise everytime together! How can I solve it?

Hello,
I have solved, as managed a few posts above.
Go to the directory: /var/lib/openhab2/config/org/openhab
Edit file : addons.config
look for the misc= line and delete param restdocs
reboot

1 Like

I have the same error, but my addons.config has the following in MISC?
misc=“ruleengine”

Any Ideas.

Thanks

I have no text file at all referencing rest docs but get this error constantly through all the versions since over a month (since I took notice of it).

Can that be any relic from an old version? I am using OpenHAB on this instance since 2.1.