#1534 --- Failed installing 'openhab-misc-restdocs'

Tags: #<Tag:0x00007f616e1d0688>

How did you install it originally? Probably in addons.cfg?

Nope, neither 'services\addons.cfg nor ‘addons.config’ was not used.

I had the same problem with 2.5.0.M2 and Mail-Action.
I got the problem solved after enabling Legacy v1.x Binding Support.
Then I could UNINSTALL the old Mail-Action Bindings.

1 Like

I have this same issue. Can’t find a 1.X version to install to remove, it was never in my addons.cfg. On 2.4M4.

You meen 2.5M4? I just did as described above with great success, remove the line misc=“restdocs” from addons.conf:

solved it! Thx

Worked for me - much appreciated!

Same situation here. addons.cfg is fully commented. Can’t find the Legacy version to remove the old openhab-misc-restdocs. On 2.5_M5


I bet you have addons.config in folder




Please check the misc and legacy entries inside this file.

And it does not exist a legacy version of restdocs. In above mentioned post the author said, that he could not install or uninstall a legacy binding or action, because it was set legacy=false in addons.config.

1 Like

Thanks for the suggestions @Celaeno1
I got this fixed.

The only copy is under conf/services:

openhab@pi-openhab> find . -name “addons.cfg”

The file is essentially empty, as every line is commented:

# See https://www.openhab.org/docs/configuration/packages.html for a detailed    explanation of these packages.
#package = minimal

# Access Remote Add-on Repository
# Defines whether the remote openHAB add-on repository should be used for browsing and installing add-ons.
# This not only makes latest snapshots of add-ons available, it is also required for the installation of
# any legacy 1.x add-on. (default is true)
#remote = true

# Include legacy 1.x bindings. If set to true, it also allows the installation of 1.x bindings for which there is
# already a 2.x version available (requires remote repo access, see above). (default is false)
#legacy = true

# A comma-separated list of bindings to install (e.g. "binding = sonos,knx,zwave")
#binding =

# A comma-separated list of UIs to install (e.g. "ui = basic,paper")
#ui =

# A comma-separated list of persistence services to install (e.g. "persistence = rrd4j,jpa")
#persistence =

# A comma-separated list of actions to install (e.g. "action = mail,pushover")
#action =

# A comma-separated list of transformation services to install (e.g. "transformation = map,jsonpath")
#transformation =

# A comma-separated list of voice services to install (e.g. "voice = marytts,freetts")
#voice =

# A comma-separated list of miscellaneous services to install (e.g. "misc = myopenhab")
#misc =

The solution was to uncomment the misc line and add the misc bindings I want to keep (I only use openhabcloud), like this:

misc = openhabcloud 

Then restart. No more openhab-misc-restdoc errors after that

Perhaps this is what was being suggested all along and I just didn’t interpret it correctly.

Thanks for the help!

1 Like

Thank you! I spent hours on this annoyance.

BUT it’s kludgey. I too added a redundant binding to misc= to “solve” the problem. I think it’s only a matter of time before this “fix” comes back to bite me.

You probably shouldn’t add any add-ons to services/addons.cfg if you’ve installed them all using the UI. If you do it will probably uninstall all add-ons that were previously installed using the UI.

The best way to prevent this for users that install add-ons using the UI is to uninstall the REST docs before updating. See Breaking Changes in the 2.5.0 release notes.


I followed a tutorial that recommended specifying bindings within addons.cfg rather than using paper UI, with a caveat about paper UI-installed bindings being removed.

I added misc = market to addons.cfg and haven’t seen any adverse effects in Paper UI.

Remembering to uninstall the REST docs before updating is something I would certainly forget to do. I’d guess that most people would not uninstall the docs either.

Yes this shouldn’t be standard procedure so that’s why it’s added to the release notes. It’s the first item in the breaking changes list so it should have a lot of exposure to users that read it. Let’s hope many users doing the upgrade don’t end up here. :crossed_fingers:

So, here I am, getting the same error

2019-12-30 18:29:18.836 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-misc-restdocs’

just after upgrading to 2.5 5 minutes ago.

Just the short version: what do I have to do now?

PS here is my addons.config file:


Just removing the “restdocs” from the “misc” line should do it


thanks, that did the trick

I’ve removed it but getting this error time and time again

root@openhab-slave-eg:/var/log/openhab2# grep “Failed installing ‘openhab-misc-restdocs’” openhab.log
2019-12-31 16:28:37.452 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-misc-restdocs’
2019-12-31 16:28:53.756 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-misc-restdocs’
2019-12-31 16:29:30.659 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-misc-restdocs’
2019-12-31 16:30:38.256 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-misc-restdocs’
2019-12-31 16:31:32.325 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-misc-restdocs’

the same for me, I’ve removed the entry in addons.cfg but the error appears every minute.

" REST Docs

This add-on is now part of the UIs. When previously installed using a UI, uninstall the REST Docs before updating and reinstall it after the update to prevent errors. When installing it using textual configuration, update services/addons.cfg by removing restdocs from misc and add it to ui instead."

If you updated the addons and it is still giving error you can try clearing the cache

openHABianPi:~$ sudo systemctl stop openhab2.service
openHABianPi:~$ sudo openhab-cli clean-cache

This command will delete the temporary files within openHAB.
May resolve issues with addon installation and configuration.
The next start of openHAB will take a bit longer.

Okay to Continue? [y/N]: y
openHABianPi:~$ sudo systemctl start openhab2.service