#1534 - RESTproblem / iosApp Error 503 "Service unavailable"

My recent update from #1512 to #1534 brought in some unnice problems i try to deal with at the moment.
Seems that some changes happend to Rest API UI as i have another problem, see below.

But here it seems that ios APP often brings up the Error 503 which i have never seen before. often the app updates but if you force to update with finger gesture it shows “Service unavailabel” a lot of times. In parallel i have several ESPs requesting status of some items - these as well have errors from time to time - so definitely something does not work anymore related to API. Anyone else having issues or knows a proper fix for this. Thanks a lot! Norbert

hm, another evidence when starting the RestAPI ui i often see the following message and nothing else:

Can’t read swagger JSON from http://192.168.1.11:8080/rest/swagger.json

503 : <html> <head> <meta http-equiv="Content-Type" content="text/html;charset=utf-8"/> <title>Error 503 Jersey is not ready yet!</title> <script type="text/javascript" src="http://ff.kis.v2.scr.kaspersky-labs.com/8979FD92-99C2-F143-93D1-63EA9EF80D5C/main.js" charset="UTF-8"></script></head> <body><h2>HTTP ERROR 503</h2> <p>Problem accessing /rest/swagger.json. Reason: <pre> Jersey is not ready yet!</pre></p><hr><a href="http://eclipse.org/jetty">Powered by Jetty:// 9.4.12.v20180830</a><hr/> </body> </html> http://192.168.1.11:8080/rest/swagger.json

I already tried to clear cache and tmp but did not change anything…

Snapshots are still broken as the reorganization of OH core is ongoing. Currently, they are not recommended to be used until the end of the month (at least). 2.5.0M1 works well, and apparently 1512 worked for you too, you may need to downgrade to either.

Hello, since the hickups @build arround 1534 i now waited patiently @1512…can anyone with better insights than myself please provide feedback if its still dangerous to update to the latest dev-builds…is there still something big going on that’s work in progress?

Seemingly work is still in progress (and will be for quite some time more) but most of the recent snapshots have been working again.
However, keep in mind that nobody can give you any guarantees on snapshots…ever. They are the result of work in progress (thank you developers!) and despite best efforts, things can and do break…then they will get fixed. But if you pull the one that does not work, you will need to learn either how to downgrade or how to wait.

Markus, thanks a lot for the feedback.
No doubt, going the snapshot road will always run into minor issues - so someone should know before if its worth it. I’m more asking if the big evolution going on arround 1512 is final and this “construction site” finished. Regards Norbert

btw, nice phrase - so true :slight_smile: “you will need to learn either how to downgrade or how to wait…”

1 Like

I got my “wisdom” about the current state of the transition from here:


There are a few other threads or you can watch the github repos…