2.3.0 - wifiled/2.3.0 does not contain a manifest

You will continue to do the same.

This story with the addons.cfg was just a quick and dirty troubleshooting tip to get your OH 2.3 system back up

You can revert to the “standard” way of working again now :smiley: (just comment out the binding = line)

Issue captured:

should that be put in the addons.cfg??

Run from Karaf console.

It’s not clear to me if they can get to the console… original poster mentioned : I dont get a running system

I will try to replicate this issue on my test system to see if I can access the console also.

I tried to reinstall the wifiled binding and I got the same message as before.
thanks for open an github issue.

1 Like

Can you try the 2.4 Snapshot and let me know if it works (manually deploy it)

link: https://openhab.ci.cloudbees.com/job/openHAB2-Bundles/lastBuild/org.openhab.binding$org.openhab.binding.wifiled/

you mean drag and drop the 2.4.0 wifiled jar file to addons folder?

I’m on 2.4 snapshot and do not have the issue.

Yes. Simply download the jar file and place it in your addons folder (/usr/share/openhab2/addons)
Just like any manual deployment of an addon

yes it works!

EDIT: Also after stop and start openhab again.

1 Like

So: it seems that there was a hiccup with the wifiled binding that was included in the 2.3 Stable build.

No worries, it will be addressed by the developers and it will be fixed.

1 Like

I checked on a clean OH2.3 system and the instance does come up, so this is a better workaround (uninstall the binding from the console).

downloaded the org.openhab.binding.wifiled-2.3.0.jar on my system and saw that it is corrupted (I can’t even open it up as an archive)

Someone should fix it on mvn :slight_smile:

Uninstall via console did not work for me, but deleting the wifiled binding from the addons.cfg did the trick - thanks !

1 Like

I also had this issue and uninstalled the binding. Everything is fine now.

But I want to use this binding offcourse :slight_smile:
Will 2.3.0 get a fix or do we need to wait for openHAB 2.4.0 (or install the 2.4.0 jar manually)

yes, it will. no ETA on it though.
For now, you can grab the 2.4 snapshot jar and deploy it manually. it should be the same.

Update: The maintainers have published now a working org.openhab.binding.wifiled-2.3.0.jar on the online repo.

Perform the following steps to get the new *.jar downloaded to your system:

  1. Stop OH2.3 Service (sudo systemctl stop openhab2)
  2. Clear local tmp & cache folders from $OPENHAB_USERDATA. See: Clear the Cache
    On Linux:
sudo rm -rf /var/lib/openhab2/cache/*
sudo rm -rf /var/lib/openhab2/tmp/*

be very careful with rm -rf ! Make sure that you type the command exactly as above.

On Windows: Simply remove all files within the C:\openHAB2\userdata\tmp and C:\openHAB2\userdata\cache directories without removing these 2 folders themselves.

  1. Start OH2.3 Service (sudo systemctl start openhab2)

The system should download the *.jar again and store it in $OPENHAB_USERDATA/tmp/mvn/org/openhab/binding/org.openhab.binding.wifiled/ folder.

Now the wifiled 2.3.0 binding will appear as installed in PaperUI and you will be able to un/install other addons as well via PaperUI.

1 Like

Thanks so much that worked. Was the problem just a faulty binding that messed up the entire system then?

I can confirm, it works!

1 Like