2.5.0.M2: After upgrade automatic uninstall of bindings?


I tried two times to install the new 2.5.0.M2. Both with the same result: A sudden deinstallation of the bindings. After a successful fresh installation on a new SD card (RasPi 3B+) I restored my files via “openhab-cli restore”. I restarted and everything is good, the system starts. I see how it comes to life. And after the most bindings are there, there is a sudden change in behaviour and everything deinstalls.

Can it be related to me doing a restore? Could an “old” file of the backup be responsible for uninstalling the most important bindings?

Anyone any hint?

Thanks in advance!

I think that might happen if you use both Paper UI for installing add-ons and also install them using the addons.cfg file. The add-ons in the addons.cfg file will then override those installed via Paper UI.

Hey @wborn,

thanks for fast reply!

Do you mean the file in openHAB conf/services/addons.cfg? I do not use it. Is there another one?


Yes that’s the file I meant.

After installing add-ons via Paper UI and that addons.cfg they are added to another file:


So you could check if it is properly updated whenever you install the add-ons via Paper UI. It might fail e.g. when openHAB doesn’t have sufficient permissions for updating the file.