[3.0 M3] Problem with Serial device / Smart Meter Binding

Has anybody tried with Serial devices under Linux?

I’ve just testing on my production system (yeah, I know :wink: ) and noticed that /dev/ttyUSB0 can’t be accessed by the smartmeter binding:

2020-12-05 13:49:21.150 [INFO ] [ding.smartmeter.internal.MeterDevice] - Opening connection to smartmeter:meter:7a73a9f7a2
2020-12-05 13:49:21.153 [WARN ] [ding.smartmeter.internal.MeterDevice] - Failed to read: No provider for port /dev/ttyUSB0 found. Closing connection and trying again in 2 seconds...; smartmeter:meter:7a73a9f7a2
java.lang.IllegalStateException: No provider for port /dev/ttyUSB0 found

User permissions are the same as before the “upgrade” for user openhab:

# id openhab
uid=109(openhab) gid=114(openhab) groups=114(openhab),5(tty),20(dialout),29(audio),113(bluetooth),997(gpio)

Device is fine:

root@openhab2:/home/pi# ls -l /dev/ttyUSB0
crw-rw---- 1 root dialout 188, 0 Feb 14  2019 /dev/ttyUSB0

I’ve tested with additional options in /etc/default/openhab but no succes:

Any suggestions on this?


Everybody using Zigbee & Z-Wave.

I had to manually install the feature openhab-core-io-transport-serial-javacomm:

  • open openhab-cli console
  • run “feature:install openhab-core-io-transport-serial-javacomm”

Issue should be resolven :+1:

1 Like

Normally we are using rxtx implementation. You did not install the right feature. But could work too, I am not sure that this implementation was as much tested.

Yes, I thought so too but I’ve installed one-by-one and monitored the logs. This one fixed it