3rd Party Bluetooth Binding. Beta testers needed

bluetooth
binding
Tags: #<Tag:0x00007f0156c51968> #<Tag:0x00007f0156c51760>

(CM6.5 H102) #685

Your not using openhabian image…:hushed:

How did you install OH, via repository or manual?

What’s output of
$groups


(Tom) #686

I used package setup, if I remember correctly.

pi adm dialout cdrom sudo audio video plugdev games users input netdev gpio i2c spi

Thanks


(Vlad Kolotov) #687

hi @Tommyshome, @H102 (thanks for you help),

you can definitely use a package manager to install OH (it is not necessary to use a bundled image from OH).

The problem you are having is something to do with permissions. Obviously your openhab user can’t access Bluez via DBus.

You either need to add “openhab” user into “lp” group, or follow my instructions (that you stated above) to add “bluetooth” group and have openhab user assigned to that group. Either way should work.

The easiest way to debug the issue is to use bluetoothctl utility as it is controlling bluetooth via DBus, essentially in the same way as OH binding.

Please run this:

pi@raspberrypi:~ $ bluetoothctl 
[blahblah]# list
Controller XX:XX:XX:XX:XX:XX AZIO - Entrance hall [default]
Controller XX:XX:XX:XX:XX:XX AZIO - Living area 
Controller XX:XX:XX:XX:XX:XX Internal Adapter - Kitchen 

Expect to see a list of adapters. If not seen, or error occurs, than something goes wrong and the binding won’t work.

Update: @Tommyshome, normally you do not add adapters manually, they should appear in the inbox (giving that your Bluez is up and running and openhab user has access to it though DBus).


(Tom) #688

Thanks to both of you!
Running bluetoothctl I see a list of three devices.
First one and default Bluez 5.47


(Vlad Kolotov) #689

Thanks @Tommyshome, did you run that command as “pi” user? If so, could you please ru it as “openhab” user as per this:

sudo -u openhab bluetoothctl

(Tom) #690

Thanks @vkolotov!
There it stucks:
pi@raspberrypi:~ $ sudo -u openhab bluetoothctl
[bluetooth]# nnect to bluetoothd…


(CM6.5 H102) #691

From there you should be able to type list and see your controller. To get out type exit


(Tom) #692

Nothing:

pi@raspberrypi:~ $ sudo -u openhab bluetoothctl
[bluetooth]# listt to bluetoothd…
[bluetooth]# list
[bluetooth]# exit
pi@raspberrypi:~ $


(CM6.5 H102) #693

Have you tried using just bluetoothctl or is the sudo -u openhab needed?


(Tom) #694

bluetoothctl same result
sudo bluetoothctl gives me a list of three devices

Thanks


(Vlad Kolotov) #695

It clearly shows that your “openhab” user does not permissions to work with bluetooth.

Please run this:

groups openhab

Then if you don’t see “lp” in the output, then do this:

sudo usermod -a -G lp openhab

Make sure that you can see your adapters by using bluetoothctl utility:

sudo -u openhab bluetoothctl

Then restart bluetooth daemon and OH:

sudo /etc/init.d/bluetooth restart
sudo /etc/init.d/openhab2 restart

(Tom) #696

Thanks @vkolotov!
“lp” was not in groups, now it is!
But running sudo -u openhab bluetoothctl I don’t see anything…


(Tom) #697

pi@raspberrypi:~ $ sudo -u openhab bluetoothctl
[bluetooth]# nnect to bluetoothd…

Also the command “list” gives no output.
Just with the command “sudo bluetoothctl” I find the Bluez 5.47 controller


(Tom) #698

Installed again Bluez 5.47 and now it is working!!!
Thank you very much @vkolotov and @H102 !!!


(Neil) #699

hi vlad,

Thanks for the binding, I’m already using it for a few itags.

I’m available to help test the eQ-3 radiator thermostat if/when you’re able to start working on that.


(Vlad Kolotov) #700

Hi @DSTM, I’ll be happy to help you. At the moment we are working on Soma blinds, hoping that it will be released soon. This also will contribute to the core of the binding, so in a way, we are working on eQ-3 as well.


(Tom) #701

Meanwhile I understood what was happening in my case. I had some problems with the groups
and thanks again to @vkolotov and @H102.
Then I had also problems with permissions and this was due to making the first installation with the super user!
So, for those interested, install the tinyB with “pi” user!


(Gad Ofir) #702

Hi please help

i installed IOT market
but i cannot find the bluegiga binidng or any related from here , stuck after step 3, not able to find any binding


(Daniel N.) #703

Update to my matter.
After Cache and Temp delete, it work great :slight_smile:

Thank you, its a greate Binding


(Gad Ofir) #704

@vkolotov vlad? :slight_smile: