433mhz module

Tags: #<Tag:0x00007f6182975398> #<Tag:0x00007f61829751b8>

So you use wiringpi 2 for both.

Isn’t supposed to be so?!
Your link for RFmqtt.cpp has pin#3 so i changed it to 27 so that can equal to pin 2 of wiringpi diagram for RFSniffer
And by the way i have tried rfmqtt with pin3 and multiple pins and same nothing happens!
I am now trying Stretch and going to Try Jessie and will update back …

When you have the corect pin for rfsniffer and you recieve something than you can usw this pin also for RFmqtt.

@Josar

sorry to bother you @Josar
i been trying my best with this but no moving forward yet, i dont like to give up on this yet cause i know it worked perfect for me before so here is what i have seen on my logs

when i hit this line
mosquitto_sub -u admin -P adminpassword -v -h 192.168.2.140 -p 1883 -t '#'
i do receive signal from my 433mhz door sensor
also my logs now seems to be changed for better, i can see it receiving the signal here : mymosquitto.log (182.1 KB)

using MQTT.fx i do get signal between both no problem

when i run ./RFmqtt which is inside my 433Utils/RPi
i receive nothing, i do think its the mosquitto problem still for some reason!

I don’t understand what you try to tell me here.

How can you recieve a mqtt message with the 433Mhz topic if RFmqtt does not work?

For me this sounds as if you allready have RFmqtt running as deamon. And thus the 433Mhz door sensor is allready translated to an mqtt topic. Now you need to configure Openhab MQTT to receive this MQTT topics.

I think there is a embedded MQTT broker which can be enabled or use Mosquitto (or any other) as broker. Also you will need to install the MQTT binding. See this thread which explains this in detail.

@Josar

Hi, i have mentioned that my when i run RFmqtt i get no signal no error no nothing, i put up my logs and if you check i do get a signal from my sensor, regarding the OH i cant get it to connect if RFmqtt not receiving signal, i have read everything regarding the OH new mqtt embedded and other bidding that belongs to MQTT and all seem to be clear, my problem seems to be more with either the RFmqtt or the Mosquitto itself.

One thing, Can you confirm if the RFmqtt working for you or anyone that you know? Than i can make sure that i have problem only in myside for sure