A beginner's bad, first day - all installs fail

Hello OpenHab,

I am sorry for the beginner plea for help, but I have had an awful day trying to setup OpenHab. My first attempt was on the Raspberry Pi 3 using the predefined image but it failed to unpack/run. I then tried to install it manually, but ran into other issues (DNS?) that I couldn’t resolve.

Eventually I gave up with the with Pi and hoped that a Windows install would be easy so I could get to actually trying the app. Unfortunately, I haven’t had any luck there either. I followed the instructions and downloaded the Zulu Java, installed it, and then did the same for OpenHab. It fails to run. Note that the command window was run with Admin rights. The printout is here:

C:\OpenHAB2>echo %JAVA_HOME%
C:\Program Files\Zulu\zulu-9

Launching the openHAB runtime…
karaf.bat: Ignoring predefined value for KARAF_HOME
-Djava.endorsed.dirs=C:\Program Files\Zulu\zulu-9\jre\lib\endorsed;C:\Program Fi
les\Zulu\zulu-9\lib\endorsed;C:\OpenHAB2\runtime\bin…\lib\endorsed is not supp
orted. Endorsed standards and standalone APIs
in modular form will be supported via the concept of upgradeable modules.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

I then changed to Oracle Java, but OpenHab still fails to run. In this case, it hangs. (I waited over 30 minutes, thinking that the first start might be slow.)

C:\OpenHAB2>echo %JAVA_HOME%
C:\Program Files (x86)\Java\jre1.8.0_161

Launching the openHAB runtime…
karaf.bat: Ignoring predefined value for KARAF_HOME
WARNING: Running Karaf on a Java HotSpot Client VM because server-mode is not av
Install Java Developer Kit to fix this.
For more details see http://java.sun.com/products/hotspot/whitepaper.html#client

Terminate batch job (Y/N)? y


I realize this is probably a very basic problem to those familiar with OpenHab, but I can’t find anything (I tried plowing threw the forums, but find forums hard to use. Google searches didn’t help either.)

Is there a Java problem? There could be now since 2 are installed, but only one is referenced in the “JAVA_HOME” environmental variable.

I appreciate any input that people could provide.
Thank you!

By predefined image, do you mean openHABian? What did you try to unpack it with, and is it compatible with xz files?

As for Windows, all I can recommend is to read through the docs… https://docs.openhab.org/installation/windows.html. I run on Fedora, but have played with it a couple times on Windows10 and didn’t run into any issues.

Hi Scott, thanks for the reply.

For the Pi, I followed the instructions here: https://docs.openhab.org/installation/openhabian.html

I downloaded the image and then wrote the image to the SD card using etcher. I then installed the card and powered up the Pi. I was not able to connect to the Pi (as the instructions say you can), but with DHCP I wasn’t sure of the new IP address (so I tried them all). After about an hour, I stopped the Pi (hoping that it was more than enough time to do whatever it needed), and then set up a static IP so I could connect to it. At that point, I could SSH into it and see the log - that almost nothing had been done. It seems that the image did not set itself up as expected.

The ultimate goal is to get back to the Pi, but after many hours of failing with it, I just wanted a simple install to start getting used to OpenHab. That is when I went to Windows.

Unfortunately, the install on Windows 7 took several hours as well, and still will not boot. I have tried following all the documentation that I could find, and tried finding people’s posts with similar issues.

Usually openHABian works like a ke a charm, maybe you had a bad write or bad sd card?

You should try again. Could you add an hdmi device (monitor, tv) to the pi, just to see what happens?