Aborting launch - no such file.. Install problem. Is this a directory question?

  • Platform information: Mac OS 10.10.5 Yosemite
    • Hardware: CPUArchitecture/RAM/storage 2.13 GHz Intel Core 2 Duo

Hi - I am very unfamiliar with command line interfaces (terminal). I am mac based and have just downloaded the zulu dmg which unpacked, ran and installed ok (I can see zulu in my java folder on my mac using finder) I have also downloaded openhab and can see an ‘openhab’ folder in my downloads folder on the same mac.

I can fire up terminal and navigate to the openhab directory. However, when I run ./start.sh in terminal the process starts but then I get the following message:

Launching the openHAB runtime…
Unable to find any JVMs matching version “1.8”.
Java 1.8 or higher is required. Aborting launch.
/openhab/runtime/bin/setenv: line 114: /bin/true: No such file or directory

I’m not sure how to tell what it is looking for in line 114 but it seems to be unable to find any JVM which I assume is a java virtual machine… Do I need to do something extra with zulu to ‘start’ a virtual machine before I run the start.sh command in the openhab folder?

Many thanks for any advice!

Did you by chance download Zulu 9? OH only supports running on 8.

What happens when you type java -version on the terminal?

Yes I think I downloaded 9!

Thank you so much - will try version 8…