About integrating ZigBee Kwikset 910 series lock(solved)

Hi there,
Anyone have used Kwikset 910 lock before? I use Elelabs ZigBee USB adapter to integrate ZigBee devices.
The lock could be connected to openhab. However, it only shows the temperature, battery and voltage of the lock, which means I can’t open/close the lock. See attached picture.
Anyone have faced this issue before? I appreciate anyone could give me some help and idea.


Please see here -:

The issue will be the same, so I suggest we discuss in one place - can you also provide the XML I file requested in that thread?

Hi Chris,
I know in other thread, the guy who has similar issues with smart lock seems pretty urgent. I’m not in a hurry. But I just want to make sure you’ve already received my XML file, which I send to you almost 10 days ago.

Yes - I did receive this - thanks. Hopefully we can get this into the binding soon…

Hi Chris,
I have a Samsung water leak sensor, and it has a same issues, only shows temperature channel. The water leak channel doesn’t show up. So can you please tell me what I should do? Send you the XML file again?

I don’t think this is related to the door lock so we probably should have started a different thread? Anyway, please ensure that you have the latest version of the binding as flood sensor was added recently. If you have the latest version, and it’s not working, then yes, please send me the XML again and I’ll take a look.

Hi Chris,
Looks like the lock has already added into the binding in the other thread. So how’s my lock bind?
Will it finish soon?

This has not been added yet - no locks are currently supported in the binding as the PR is still not merged -:

Hi Chris,
How’s the binding process of the smart lock? Looking forward to your reply.

Looks like the change was merged 2 days ago, so we’ll need to wait for another build now. Still on 2.4.0-M4, looks like.

As @peterloron said, this was merged a few days back. If you are on the snapshot version, then it should now be included, otherwise it will be in the next milestone release in a week or two (I guess).

Let me know how it works - the other user who requested this managed to get it working with a version I compiled for him, so hopefully it is working ok :wink: .

I also have a Kwikset Zigbee deadbolt I’m hoping to get working with openhab, so I’m following along closely.

This should be included in the binding now, so let me know how it goes. Currently, I’ve only added the lock itself and not all the other “stuff” that locks tend to support…

I’ve been trying to find a ZigBee lock in the UK that I can get for testing against, but they don’t seem very available…

Hi Chris,
Thanks for your hardworking. But It looks like the lock still only shows the battery and temperature channel. I haven’t the lock channel. See the figure below. Let me know what I should do next. Thanks.

Just to be clear, can you confirm what version you are running please? (eg show the output from karaf list command).

Hi Chris,
I think I use the

this file on the Raspberry Pi. The version maybe 2.2.
Unfortunately, I was not able to connect to the console. It shows some errors. See figure below,

Ok, I’m not exactly sure what that version is, but the date is 6 months old, so for sure it will not include any recent updates.

Please use a very recent snapshot version - ie within the last week.

Hi Chris,
I still can’t enter karaf console, I also can’t find the on/off channel of lock. Can you tell how to update the zigbee binding manually, or other ways to update the zigbee bindings?

Please use the snapshot runtime. I don’t know what system you are using, but read through the docs of your system and it should tell you how to install different versions - select the snapshot and you will have the latest version.

I have personally tested the lock now, so I know it works if you get a newer version of the binding.

I’m using raspberry pi 3 b+. I think the version I use 2.2. I can’t enter karaf console, and I’ve already reinstall the system a few times, but there still exits same problems.
Can you tell me how to update zigbee binding at raspberry pi 3 b+.