Absurd high value received from temp sensor(s)

I’ve had 2 events from 2 different temperature sensors where I got some absurd values.

The first happened about a month ago on my new Fibaro smoke detector FGSD002 where it suddenly reported a temperature of 226.8 © and the second incident was on my fibaro multisensor FGMS001 reporting 431 © degrees.

Has anyone else experienced this or similar? No clue if this is a software glitch by openhab/binding or a bug in the devices…although my money is on the latter.

SMOKE DETECTOR EVENT
events.log:
2015-10-22 20:17:03 - Brannvarsler_Temp_Kj_Kinorom state updated to 226.8

zwave.log
2015-10-22 20:17:03.057 [DEBUG] [ApplicationCommandMessageClass:38 ]- NODE 45: Application Command Request (ALIVE:DONE)
2015-10-22 20:17:03.057 [DEBUG] [ApplicationCommandMessageClass:56 ]- NODE 45: Incoming command class SENSOR_MULTILEVEL
2015-10-22 20:17:03.058 [DEBUG] [veMultiLevelSensorCommandClass:97 ]- NODE 45: Received Sensor Multi Level Request
2015-10-22 20:17:03.058 [DEBUG] [veMultiLevelSensorCommandClass:131 ]- NODE 45: Sensor Multi Level REPORT received
2015-10-22 20:17:03.058 [DEBUG] [veMultiLevelSensorCommandClass:141 ]- NODE 45: Sensor Type = Temperature(1), Scale = 0
2015-10-22 20:17:03.059 [DEBUG] [veMultiLevelSensorCommandClass:150 ]- NODE 45: Sensor Value = 22.1
2015-10-22 20:17:03.060 [DEBUG] [b.z.i.protocol.ZWaveController:682 ]- Notifying event listeners: ZWaveMultiLevelSensorValueEvent
2015-10-22 20:17:03.060 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ]- ZwaveIncomingEvent
2015-10-22 20:17:03.060 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ]- NODE 45: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_MULTILEVEL, value = 22.1
2015-10-22 20:17:03.061 [DEBUG] [ApplicationCommandMessageClass:85 ]- Transaction not completed: node address inconsistent.
2015-10-22 20:17:03.073 [DEBUG] [eController$ZWaveReceiveThread:1528]- Receive Message = 01 0C 00 04 10 2D 06 31 05 01 22 00 DD 06
2015-10-22 20:17:03.075 [DEBUG] [eController$ZWaveReceiveThread:1452]- Receive queue ADD: Length=1
2015-10-22 20:17:03.075 [DEBUG] [b.z.i.protocol.ZWaveController:1210]- Receive queue TAKE: Length=0
2015-10-22 20:17:03.077 [DEBUG] [o.b.z.i.protocol.SerialMessage:233 ]- Assembled message buffer = 01 0C 00 04 10 2D 06 31 05 01 22 00 DD 06
2015-10-22 20:17:03.078 [DEBUG] [b.z.i.protocol.ZWaveController:1211]- Process Message = 01 0C 00 04 10 2D 06 31 05 01 22 00 DD 06
2015-10-22 20:17:03.079 [DEBUG] [b.z.i.protocol.ZWaveController:190 ]- Message: class = ApplicationCommandHandler (0x04), type = Request (0x00), payload = 10 2D 06 31 05 01 22 00 DD
2015-10-22 20:17:03.080 [DEBUG] [ApplicationCommandMessageClass:38 ]- NODE 45: Application Command Request (ALIVE:DONE)
2015-10-22 20:17:03.080 [DEBUG] [ApplicationCommandMessageClass:56 ]- NODE 45: Incoming command class SENSOR_MULTILEVEL
2015-10-22 20:17:03.081 [DEBUG] [veMultiLevelSensorCommandClass:97 ]- NODE 45: Received Sensor Multi Level Request
2015-10-22 20:17:03.081 [DEBUG] [veMultiLevelSensorCommandClass:131 ]- NODE 45: Sensor Multi Level REPORT received
2015-10-22 20:17:03.082 [DEBUG] [veMultiLevelSensorCommandClass:141 ]- NODE 45: Sensor Type = Temperature(1), Scale = 0
2015-10-22 20:17:03.083 [DEBUG] [veMultiLevelSensorCommandClass:150 ]- NODE 45: Sensor Value = 22.1
2015-10-22 20:17:03.083 [DEBUG] [b.z.i.protocol.ZWaveController:682 ]- Notifying event listeners: ZWaveMultiLevelSensorValueEvent
2015-10-22 20:17:03.084 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ]- ZwaveIncomingEvent
2015-10-22 20:17:03.084 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ]- NODE 45: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_MULTILEVEL, value = 22.1
2015-10-22 20:17:03.085 [DEBUG] [ApplicationCommandMessageClass:85 ]- Transaction not completed: node address inconsistent.
2015-10-22 20:17:03.092 [DEBUG] [eController$ZWaveReceiveThread:1528]- Receive Message = 01 0C 00 04 10 2D 06 31 05 01 22 00 DD 06
2015-10-22 20:17:03.099 [DEBUG] [eController$ZWaveReceiveThread:1452]- Receive queue ADD: Length=1
2015-10-22 20:17:03.099 [DEBUG] [b.z.i.protocol.ZWaveController:1210]- Receive queue TAKE: Length=0
2015-10-22 20:17:03.101 [DEBUG] [o.b.z.i.protocol.SerialMessage:233 ]- Assembled message buffer = 01 0C 00 04 10 2D 06 31 05 01 22 00 DD 06
2015-10-22 20:17:03.102 [DEBUG] [b.z.i.protocol.ZWaveController:1211]- Process Message = 01 0C 00 04 10 2D 06 31 05 01 22 00 DD 06
2015-10-22 20:17:03.103 [DEBUG] [b.z.i.protocol.ZWaveController:190 ]- Message: class = ApplicationCommandHandler (0x04), type = Request (0x00), payload = 10 2D 06 31 05 01 22 00 DD
2015-10-22 20:17:03.103 [DEBUG] [ApplicationCommandMessageClass:38 ]- NODE 45: Application Command Request (ALIVE:DONE)
2015-10-22 20:17:03.104 [DEBUG] [ApplicationCommandMessageClass:56 ]- NODE 45: Incoming command class SENSOR_MULTILEVEL
2015-10-22 20:17:03.105 [DEBUG] [veMultiLevelSensorCommandClass:97 ]- NODE 45: Received Sensor Multi Level Request
2015-10-22 20:17:03.105 [DEBUG] [veMultiLevelSensorCommandClass:131 ]- NODE 45: Sensor Multi Level REPORT received
2015-10-22 20:17:03.106 [DEBUG] [veMultiLevelSensorCommandClass:141 ]- NODE 45: Sensor Type = Temperature(1), Scale = 0
2015-10-22 20:17:03.107 [DEBUG] [veMultiLevelSensorCommandClass:150 ]- NODE 45: Sensor Value = 22.1
2015-10-22 20:17:03.107 [DEBUG] [b.z.i.protocol.ZWaveController:682 ]- Notifying event listeners: ZWaveMultiLevelSensorValueEvent
2015-10-22 20:17:03.108 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ]- ZwaveIncomingEvent
2015-10-22 20:17:03.108 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ]- NODE 45: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_MULTILEVEL, value = 22.1
2015-10-22 20:17:03.110 [DEBUG] [ApplicationCommandMessageClass:85 ]- Transaction not completed: node address inconsistent.
2015-10-22 20:17:03.116 [DEBUG] [eController$ZWaveReceiveThread:1528]- Receive Message = 01 0C 00 04 10 2D 06 31 05 01 22 00 DD 06
2015-10-22 20:17:03.119 [DEBUG] [eController$ZWaveReceiveThread:1452]- Receive queue ADD: Length=1
2015-10-22 20:17:03.119 [DEBUG] [b.z.i.protocol.ZWaveController:1210]- Receive queue TAKE: Length=0
2015-10-22 20:17:03.120 [DEBUG] [o.b.z.i.protocol.SerialMessage:233 ]- Assembled message buffer = 01 0C 00 04 10 2D 06 31 05 01 22 00 DD 06
2015-10-22 20:17:03.121 [DEBUG] [b.z.i.protocol.ZWaveController:1211]- Process Message = 01 0C 00 04 10 2D 06 31 05 01 22 00 DD 06
2015-10-22 20:17:03.122 [DEBUG] [b.z.i.protocol.ZWaveController:190 ]- Message: class = ApplicationCommandHandler (0x04), type = Request (0x00), payload = 10 2D 06 31 05 01 22 00 DD
2015-10-22 20:17:03.123 [DEBUG] [ApplicationCommandMessageClass:38 ]- NODE 45: Application Command Request (ALIVE:DONE)
2015-10-22 20:17:03.124 [DEBUG] [ApplicationCommandMessageClass:56 ]- NODE 45: Incoming command class SENSOR_MULTILEVEL
2015-10-22 20:17:03.125 [DEBUG] [veMultiLevelSensorCommandClass:97 ]- NODE 45: Received Sensor Multi Level Request
2015-10-22 20:17:03.125 [DEBUG] [veMultiLevelSensorCommandClass:131 ]- NODE 45: Sensor Multi Level REPORT received
2015-10-22 20:17:03.126 [DEBUG] [veMultiLevelSensorCommandClass:141 ]- NODE 45: Sensor Type = Temperature(1), Scale = 0
2015-10-22 20:17:03.127 [DEBUG] [veMultiLevelSensorCommandClass:150 ]- NODE 45: Sensor Value = 22.1
2015-10-22 20:17:03.127 [DEBUG] [b.z.i.protocol.ZWaveController:682 ]- Notifying event listeners: ZWaveMultiLevelSensorValueEvent
2015-10-22 20:17:03.128 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ]- ZwaveIncomingEvent
2015-10-22 20:17:03.133 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ]- NODE 45: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_MULTILEVEL, value = 22.1
2015-10-22 20:17:03.135 [DEBUG] [ApplicationCommandMessageClass:85 ]- Transaction not completed: node address inconsistent.
2015-10-22 20:17:03.335 [DEBUG] [eController$ZWaveReceiveThread:1528]- Receive Message = 01 0C 00 04 10 2D 06 31 05 01 22 08 DC 0F
2015-10-22 20:17:03.337 [DEBUG] [eController$ZWaveReceiveThread:1452]- Receive queue ADD: Length=1
2015-10-22 20:17:03.337 [DEBUG] [b.z.i.protocol.ZWaveController:1210]- Receive queue TAKE: Length=0
2015-10-22 20:17:03.339 [DEBUG] [o.b.z.i.protocol.SerialMessage:233 ]- Assembled message buffer = 01 0C 00 04 10 2D 06 31 05 01 22 08 DC 0F
2015-10-22 20:17:03.340 [DEBUG] [b.z.i.protocol.ZWaveController:1211]- Process Message = 01 0C 00 04 10 2D 06 31 05 01 22 08 DC 0F
2015-10-22 20:17:03.340 [DEBUG] [b.z.i.protocol.ZWaveController:190 ]- Message: class = ApplicationCommandHandler (0x04), type = Request (0x00), payload = 10 2D 06 31 05 01 22 08 DC
2015-10-22 20:17:03.341 [DEBUG] [ApplicationCommandMessageClass:38 ]- NODE 45: Application Command Request (ALIVE:DONE)
2015-10-22 20:17:03.341 [DEBUG] [ApplicationCommandMessageClass:56 ]- NODE 45: Incoming command class SENSOR_MULTILEVEL
2015-10-22 20:17:03.342 [DEBUG] [veMultiLevelSensorCommandClass:97 ]- NODE 45: Received Sensor Multi Level Request
2015-10-22 20:17:03.342 [DEBUG] [veMultiLevelSensorCommandClass:131 ]- NODE 45: Sensor Multi Level REPORT received
2015-10-22 20:17:03.343 [DEBUG] [veMultiLevelSensorCommandClass:141 ]- NODE 45: Sensor Type = Temperature(1), Scale = 0
> 2015-10-22 20:17:03.343 [DEBUG] [veMultiLevelSensorCommandClass:150 ]- NODE 45: Sensor Value = 226.8
2015-10-22 20:17:03.344 [DEBUG] [b.z.i.protocol.ZWaveController:682 ]- Notifying event listeners: ZWaveMultiLevelSensorValueEvent
2015-10-22 20:17:03.344 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ]- ZwaveIncomingEvent
> 2015-10-22 20:17:03.345 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ]- NODE 45: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_MULTILEVEL, value = 226.8
2015-10-22 20:17:03.346 [DEBUG] [ApplicationCommandMessageClass:85 ]- Transaction not completed: node address inconsistent.
2015-10-22 20:17:05.281 [DEBUG] [o.b.z.i.protocol.SerialMessage:109 ]- NODE 255: Creating empty message of class = SendDataAbort (0x16), type = Request (0x00)
2015-10-22 20:17:05.283 [DEBUG] [o.b.z.i.protocol.SerialMessage:233 ]- Assembled message buffer = 01 03 00 16 EA

** FIBARO MULTISENSOR EVENT**
event.log
2015-11-14 00:28:13 - TempSensor_Fe_Stue state updated to 431

zwave.log
2015-11-14 00:28:13.932 [DEBUG] [eController$ZWaveReceiveThread:1528]- Receive Message = 01 0C 00 04 00 18 06 31 05 01 22 10 D6 38
2015-11-14 00:28:13.935 [DEBUG] [eController$ZWaveReceiveThread:1452]- Receive queue ADD: Length=1
2015-11-14 00:28:13.935 [DEBUG] [b.z.i.protocol.ZWaveController:1210]- Receive queue TAKE: Length=0
2015-11-14 00:28:13.937 [DEBUG] [o.b.z.i.protocol.SerialMessage:233 ]- Assembled message buffer = 01 0C 00 04 00 18 06 31 05 01 22 10 D6 38
2015-11-14 00:28:13.938 [DEBUG] [b.z.i.protocol.ZWaveController:1211]- Process Message = 01 0C 00 04 00 18 06 31 05 01 22 10 D6 38
2015-11-14 00:28:13.939 [DEBUG] [b.z.i.protocol.ZWaveController:190 ]- Message: class = ApplicationCommandHandler (0x04), type = Request (0x00), payload = 00 18 06 31 05 01 22 10 D6
2015-11-14 00:28:13.940 [DEBUG] [ApplicationCommandMessageClass:38 ]- NODE 24: Application Command Request (ALIVE:DONE)
2015-11-14 00:28:13.941 [DEBUG] [ApplicationCommandMessageClass:56 ]- NODE 24: Incoming command class SENSOR_MULTILEVEL
2015-11-14 00:28:13.942 [DEBUG] [veMultiLevelSensorCommandClass:97 ]- NODE 24: Received Sensor Multi Level Request
2015-11-14 00:28:13.942 [DEBUG] [veMultiLevelSensorCommandClass:131 ]- NODE 24: Sensor Multi Level REPORT received
2015-11-14 00:28:13.943 [DEBUG] [veMultiLevelSensorCommandClass:141 ]- NODE 24: Sensor Type = Temperature(1), Scale = 0
2015-11-14 00:28:13.944 [DEBUG] [veMultiLevelSensorCommandClass:150 ]- NODE 24: Sensor Value = 431
2015-11-14 00:28:13.944 [DEBUG] [b.z.i.protocol.ZWaveController:682 ]- Notifying event listeners: ZWaveMultiLevelSensorValueEvent
2015-11-14 00:28:13.945 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ]- ZwaveIncomingEvent
2015-11-14 00:28:13.946 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ]- NODE 24: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_MULTILEVEL, value = 431
2015-11-14 00:28:13.947 [DEBUG] [ApplicationCommandMessageClass:85 ]- Transaction not completed: node address inconsistent.
2015-11-14 00:28:14.189 [DEBUG] [eController$ZWaveReceiveThread:1528]- Receive Message = 01 0C 00 04 00 18 06 31 05 01 22 00 D6 28
2015-11-14 00:28:14.191 [DEBUG] [eController$ZWaveReceiveThread:1452]- Receive queue ADD: Length=1
2015-11-14 00:28:14.191 [DEBUG] [b.z.i.protocol.ZWaveController:1210]- Receive queue TAKE: Length=0
2015-11-14 00:28:14.192 [DEBUG] [o.b.z.i.protocol.SerialMessage:233 ]- Assembled message buffer = 01 0C 00 04 00 18 06 31 05 01 22 00 D6 28
2015-11-14 00:28:14.193 [DEBUG] [b.z.i.protocol.ZWaveController:1211]- Process Message = 01 0C 00 04 00 18 06 31 05 01 22 00 D6 28
2015-11-14 00:28:14.194 [DEBUG] [b.z.i.protocol.ZWaveController:190 ]- Message: class = ApplicationCommandHandler (0x04), type = Request (0x00), payload = 00 18 06 31 05 01 22 00 D6
2015-11-14 00:28:14.195 [DEBUG] [ApplicationCommandMessageClass:38 ]- NODE 24: Application Command Request (ALIVE:DONE)
2015-11-14 00:28:14.196 [DEBUG] [ApplicationCommandMessageClass:56 ]- NODE 24: Incoming command class SENSOR_MULTILEVEL
2015-11-14 00:28:14.196 [DEBUG] [veMultiLevelSensorCommandClass:97 ]- NODE 24: Received Sensor Multi Level Request
2015-11-14 00:28:14.197 [DEBUG] [veMultiLevelSensorCommandClass:131 ]- NODE 24: Sensor Multi Level REPORT received
2015-11-14 00:28:14.198 [DEBUG] [veMultiLevelSensorCommandClass:141 ]- NODE 24: Sensor Type = Temperature(1), Scale = 0
2015-11-14 00:28:14.198 [DEBUG] [veMultiLevelSensorCommandClass:150 ]- NODE 24: Sensor Value = 21.4
2015-11-14 00:28:14.199 [DEBUG] [b.z.i.protocol.ZWaveController:682 ]- Notifying event listeners: ZWaveMultiLevelSensorValueEvent
2015-11-14 00:28:14.199 [DEBUG] [.z.internal.ZWaveActiveBinding:433 ]- ZwaveIncomingEvent
2015-11-14 00:28:14.200 [DEBUG] [.z.internal.ZWaveActiveBinding:450 ]- NODE 24: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_MULTILEVEL, value = 21.4

argh, tried to fix the formatting of the logs but can’t edit the post (sorry, an error has occured) :unamused: