Access Error: 404 -- Not Found when trying to access openHAB package selection page in windows 7 64 bits

Good afternoom everyone, I’m glad to join this community.

I’ve some problems when accessing the openHAB package selection page, when executing the start.bat file it opens the command dialog for OpenHAB server and shows this:

then I put in the explorer the link to access the package selection page but shows:

Access Error: 404 -- Not Found

Cannot locate document: /

so, I readed several post about this issue and I think it could be two possible problems:

  1. the port 8080 is currently used by another PID.

  2. the .sitemap file (if I know what I mean) is missing and this file is the web page of the system or something like that.

So, I’ve applied the command netsat -naob on the (1) item and it shows this:

  TCP               LISTENING       6844

what means that the port is active but LISTENING and when the services window was checked, the PID number 6844 wasn’t seen on the window.

On the (2) item I’ve checked that inside the sitemaps folder is only the readme.txt file.

What other thing can I do to succesfully install OpenHAB and start developing?

NOTE: Almost forgot, the computer has the following java version:

java version ""
Java<TM> SE Runtime Environment <build 1.8.0_91-b14>
Java HotSpot<TM> 64-bit Server VM <build 25.91-b14, mixed mode>

First of all, update to a recent Java Version. Recomended is a version equal or higher than

Hi Hmerk, thank you for your answer, java version updated to and still the same behavior

Try disabling your Lenovo Client Security Solution (I think that this provides the tvttcsd.exe), restart OH2 and try again to access http://localhost:8080 from the same PC running OH2.

I disabled the lenovo client security solution and even tried to change the port number by adding some lines:


in but sill nothing.

Good afternoom Dim and Hans, I tried all the options you gave me without success, I’ve checked the log and I have this answer:

2017-02-13 12:55:54.435 [WARN ] [tty.util.component.AbstractLifeCycle] - FAILED default@2379f4bf{HTTP/1.1}{}: Address already in use: bind Address already in use: bind

I’ve checked the port usage with a netstat -naob and the port 8080 is currently not used by any PID, the OpenHAB runtime is the 2.0.0 downloaded again from the page and uncompressed. I’ve noted that it isn’t came with a .sitemap file, Are those files the ones who have the visual interface for installing OpenHAB?.

Right now I don’t know what else to do?.

Hi, Valery! I’ve got some problem and trying solve it much time. I was change port and all goes right! For it you should find line “8080” in file “setenv.bat” that lay in “OpenHab\runtime\bin”, and change on another port (I change on 8081).