Add openhab2 zwave binding as secondary controller

openhab2
zwave
binding
Tags: #<Tag:0x00007fe0660de118> #<Tag:0x00007fe0660ddfb0> #<Tag:0x00007fe0660dde48>

(markus buchberger) #1

Hi,
I’m quite new to the topic and experimenting with zwave and openhab now for several weeks.

I’m about to change from openhab 1.8 to openhab 2.
I found in the documentation of openhab 2 the following paragraph (http://docs.openhab.org/addons/bindings/zwave/readme.html)

Joining as a secondary controller

The binding can be added to the network as a secondary controller. This can be useful if you already have another home automation system and you want to use the binding as a secondary controller.

This is exactly what I want to do, run openhab as a secondary zwave controller with my existing Devolo Smart Home system. Unfortunately I did not find more information what exactly needs to be done in teh configuration part of openhab to achieve this. I’m using a PI3 with ZWave Stick as platform for openhab.
I already joined my zwave stick to the existing zwave network. But I get only some nodes available in openhab (probably the ones that did already exist at that point in time). If I add new devices to my devolo zwave controller, they do not show up in openhab.
Is there anyone having experience with that or has some hints? I’m especially unsure about configurations like SUC, SIS or property masterController=true/false ?

Thanks
Markus


(Max1968) #2

Hi @mbuchberger1967,

I’m now trying somthing similar, but not yet there as well. I have an existing Zipabox zwave installation which i dont want to touch, as (despite some minor issues) it is in general working fine.

But still I wanted to have current data of my sensors (basically I’m using some wall plugs, some window sensors and some motion/temperature sensors). So today I finally was able to add an Aeotec zwave stick with the OH2 binding to my existing Zipato network.

First of all on the Zipabox all seems to be still working fine - I dont see any issues there.

From an OH2 point of view there are some issues however:

  • Initially all my devices were shown as “unknown”, meanwhile the once without batteries are correctly identified. I guess I just wait a bit more until the others are recognized as well, I understand this is “normal” behaviour

  • From OH2 I can perfectly switch my plugs for example, and the changes are immediately reflected on my Zipabox. However it doesnt work the other way round… When I switch one of the plugs on the Zipabox the change is not reflected on PaperUI

  • Furthermore I think the current consumption of these plugs (they measure energy too) is not reflected “live” in OH2, in fact I font see any updates of the states.

  • I didnt try to add new zwave devices for now.

I’ve set the OH2 zwave controller as “not master” (i understand this means secondary) and SUC is turned off.

Do you have yours working meanwhile ? If yes what did you change ?

Thx,
Max


(markus buchberger) #3

Hi Max,

I was able to register my ZME Stick (on a Raspberry PI3) to my devolo network using ozwcp. With this tool I could send a command to my zwave stick that it should download the configuration from another controller in the net. As I understand it, it now works no longer as a primary controller, but still as a SUC.

With this configuration my zwave stick (and so OH2) sees all the zwave devices that were registered at my devolo controller. Unfortunately I have several devices (a ZME light switch, a devolo motion sensor) that do not react on commands of my OH2 zwave binding, but they work fine with the devolo controller.

Some devices are completely unknown (as they probably are not contained in the CD DB of Chris).

So I do not have a good working solution atm.

My best markus


(mike) #4

Hi @Max1968 ,

I am curious to how you added the Aeotec stick to your Zipato network. Was it by any chance via creating a “cluster” (which requires upgrading to a pro account?). I would greatly appreciate your insight as I am stuck and I am using exactly the same devices as yourself (Openhab2 + Aeotec Z Wave Stick and Zipabox).

Kind regards

Mike


(Max1968) #5

Unfortunately I dont remember exactly how I did this - Basically I opened a tickets with Zipato support, but even with the information I got from them it didnt work right away… As far as I remember I also did some kind of “reset” of the Aeotec stick as mentioned by Markus above. Furthermore I cant find the steps Zipato sent me back then anymore in the web gui, i did this on 1.1.38 while meanwhile zwave settings have completely changed.