Adding Z wave Node

Tags: #<Tag:0x00007f43350c5a88>

The manufacturer ID is assigned by the company owning z-wave. I guess we could me missing one. How did you determine the ID?

The ID us usually expressed in hexadecimal but the Paper UI displays in decimal.

Very good point, I forgot. I found it in Paper UI, for easy access… So we are at 0x438, then, which is the same as one of the devices further up this thread :slight_smile:

1 Like

Is there any way of “forcing” the creation of the XML file for the Z-Wave device? My “unknown” switch was added to the network as “node 7”, but I only have XML for nodes 1 to 6.

(I am not running the newest version of OpenHAB, since I still use the Tellstick binding for reading temperatures and controlling one light, and there is a bug in the Tellstick binding, so it doesn’t work on newer versions than 2.5.0 M3. )

Battery operated devices need to be kept awake long enough for the binding to complete discovery when the Thing is first added or the binding is restarted.

If it is a battery operated device the only way generally is to delete the Thing from openHAB (do NOT exclude from the network, re-discover, add the Thing, and then wake up the device periodically until the binding discovery completes.

If this is not a battery operated device, follow the instructions for the binding and post an unfiltered debug log.

The node still shows as “unknown device”. Is it not still in the database or?

You need yto update to a snapshot version of the binding if you have not done to already. The easiest way is the installer script.

Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

EDIT:
After updatibng the binding delete the Thing from OH (do NOT exclude from the network). Re-discover and add the Thing back to OH to get the new binding settings.

No.

The issue is not that the XML is not generated - the issue is that the binding hasn’t completed initialisation. Until it completes initialisation, it doesn’t have information about the device, so there is nothing to write in an XML so the XML is not generated. Forcing the binding to write the XML would not help.

1 Like

Thanks! Got the XML after following @Bruce_Osborne’s advice, and added it to the device database with all the information I was able to retrieve.

Approved.
Please hit the “Request Approval” button next time :grinning:

1 Like

Thanks! I unfortunately used “too much information” for the deviceID, so I didn’t get the “Request approval” button. I instead opened a ticket to have the deviceID resolved :slight_smile:

1 Like

Hello

I did`nt quite understand this, is there any way that you could do this? :sweat_smile:

You did not understand what?
Sihui approved the database entry and gave advice for the future. The person submitting the entry forgot one step of the process.

What do I need to do? I do not have the permissions to approve database entries anyway.

I did not quite understand this :joy:

Yuck! very bad typing. Sorry. Here is what I was trying to say…

You need to update to a snapshot version of the binding if you have not done to already. The easiest way is the installer script.

Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

EDIT:
After updating the binding delete the Thing from OH (do NOT exclude from the network). Re-discover and add the Thing back to OH to get the new binding settings.

I have not done this before, is it possible that you or anyone else do this?

I cannot download the script and install on your system.

Okay, but why do I need to update the script in the first place? :sweat_smile:
Kinda tought the node would work after it was added to the database :joy:

The database is part of the zwave binding. In order to get those changes you need to install a snapshot version of the binding that contains those changes.

Okay, but where do I get the correct snapshot version from? Is it the one that you linked me in previous post, or do I need to look the node up in the database?

I linked to an install script. Follow its directions and the script gets the snapshot binding and installs it.