Admin passwort habpanel

Hi,
I’ve lost my habpanel Admin password (stupid me). I’m searching for ways to reset this, I still have access to the Linux PC itself, but cannot login into habpanel.

thx
Uwe

I am not aware of that there is a specific admin password for habpanel. So I think you are looking for the user/password of Main UI.
To reset Main UI admin password you can follow these steps:

thx Wolfgang … as I’ve physically access to my host (older notebook running on linux) I tried to use openhab-cli console within the terminal window – but command not found …

You mean the command openhab-cli was not found ?
Please tell us more about you openhab installation - is it installed by using apt command or was it installed in a different way ? Which OH version do you use ? Which linux distribution / version do you use ? It is not openhabian ?

you can even try to get manual karaf console login:

  1. ssh to GNU/Linux console
  2. ssh openhab@localhost -p8101
  3. password is habopen
1 Like

iobroker@iobroker-HP-EliteBook-840-G3:~$ cat /etc/os-release
NAME=“Ubuntu”
VERSION=“20.04.4 LTS (Focal Fossa)”
ID=ubuntu
ID_LIKE=debian

if I’m not mistaken I installed it using the apt command.

independent what command I try to use, it’s always the same result

iobroker@iobroker-HP-EliteBook-840-G3:/$ openhab-cli info
openhab-cli: command not found

Check it with:

dpkg -l | grep openhab

Should result in something like:

ii  openhab                              3.3.0-1                             all          openhab
ii  openhab-addons                       3.3.0-1                             all          openhab-addons

If not it is not installed on that host - may be on an other …

in case openhab package is installed then openhab-cli should be there:

dpkg -L openhab | grep openhab-cli

which results in :

/usr/bin/openhab-cli
/etc/openhab-cli
/etc/openhab-cli/command-overrides.sh

first one is the command.

thx Wolfgang … it is really weird …

root@iobroker-HP-EliteBook-840-G3:~# dpkg -l | grep openhab
root@iobroker-HP-EliteBook-840-G3:~# dpkg -L openhab | grep openhab-cli
dpkg-query: package ‘openhab’ is not installed

but I can open it …
http://192.168.5.6:8082/habpanel/index.html#/

root@iobroker-HP-EliteBook-840-G3:~# ifconfig
enp0s31f6: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.5.6 netmask 255.255.255.0 broadcast 192.168.5.255