Advice on E1.31 sACN to DMX

Yes, I hav a DMX interface of Qbus and i can controll the DMX interface, colors are working. Then i disconnect Qbus and place The sACN interface in its place.
I even try switching the wires of the DMX signal to be sure ( i dont know if there is a polarity on DMX).
I even have a scope on the output. DMX signal is showing up, but doesn’t change when i send a color from OH.

I’m also trying to figuring out wireshark to see if the data from OH is transmitted to the interface.

The DMX LED on the module never lights up, is this a signal that the module doesn’t recieves the tcp/ip data?

Don‘t know. Multicast is printed on the interface, that should be used then. Are the OH system and the Interface in the same subnet? Do you have a Managed Switch? Some Block multicast.

It looks like the interface has a configuration web page, can you show a screenshot of that and your bridge configuration?

I’m starting a local configuration on my laptop to debug the configuration. Could there be a bug? Or is it me?

pfff that gives me this strange error:

I need some other software that i can test the hardware, somebody can help me out?

Don‘t set an IP address when using multicast.

The error message in your other screenshot is not the OH2 DMX binding, maybe it‘s the old one?

ok, i’ll try, thx!

I know nowt about KNX, but analyzing your events.log from post one;

OH Command arrives 245,56,60.
Prediction from autoupdate, in response to command.
autoupdate’s prediction applied as an update 245,56,60.
(All ordinary enough so far, none of this involves interaction outside OH)
450mS later, another update to 189,52,60.
That has come from the binding, it’s not unusual for the initial response to a command to be the “old” status in various technologies. Did it come from the actual device, or some cache along the way?
A few mS after that, yet another update to 244,56,60.
That’s a close match to the issued command, and it’s not unusual to see a small difference that can accounted for by rounding errors in various conversions along the way.
This again has come via the binding, almost certainly from some external source i.e. a DMX device.

All the clues here say that command got to some end device and was accepted. The rounding error makes it look even more like a “real” event, and not just a reflection from DMX bus.
Easy test to repeat the exercise with decoder unplugged.
Is there some multi-channel thing going on here, not looking at same target?

1 Like


So to recap.

You have seen the LED lights responding from Qbus ? (Unless QBus is a DMX output, not sACN output, I’ve not worked with Qbus)

And yes, DMX does have a polarity.
(It’s just that some manufacturers label the terminals incorrectly)

So in theory, as long as nothing else is trying to send data to your sACN adapter, it should just be a matter of matching OH’s configuration to what works for you in Qbus ?

Personally, I struggle with getting the sACN / Art-NET bridges working in text files, but I did manage it once and I have put up an example here -

#J-N-K’s binding is rock solid, so once you get it configured correctly, you should be okay.

One thought…

I don’t think that the sACN adapters report back their online status, so I’m going to assume that when an Art-NET or sACN bridge is shown as Online, it simply means that OH has not “failed to initialise” it.

And one small technical detail.

DMX is strictly a One Direction protocol.

Master unit (transmitter based loosely on RS485) issue a strictly timed data stream, which all slave devices listen to.

RDM protocol was developed as a bi-directional version, so that fixtures could be polled for their status.


You’re only setting up s small network, I would advise a Uni-cast bridge.

1 Like


I found this little app on Google Play.

It’s a little fiddly to set up, but I’m finding it really useful for testing single universe Art-NET or sACN

I am using the same bridge. Had problems to get it running with openHAB.

Solution for me was to configure a local address for the bridge in openHAB setup.

Config File (but it’s also possible to do this in GUI):
Bridge dmx:sacn-bridge:myDMXbridge [ mode=“multicast”, localaddress=“YOUR_OPENHAB_IP”, universe=1 ] {


That forces the selection of a specific network interface. Maybe in some setups multicast is send to the loopback or some other interface that cannot reach the bridge.

1 Like

thanks for the advice! I’m busy with another project for the moment, but next week i will look in to it.

So i had to try today.
I’ve found a freeware software for windows, wich can log sACN devices :slight_smile:
The logger shows this:
When i change my colors on openHAB, so openHAB side is ok.

The software also shows a list of found devices on the network. My raspberry pi with openHAB was found by the software. But it didn’t found my Brige!?!?

I’m on fixed ip now and i can reach te web page for settings.

Also added the parameter localaddress to my configuration.

Still no output on the Bridge.

Try to get the bridge running first with a DMX Software like
Connect the bridge directly to your Laptop.

The webinterface of the bridge is just for the settings. DMX protocol is UDP, maybe you have Firewall, Router or something that blocks UDP broadcasts. If connect the bridge directly to a network port of your computer, you can eliminate one possible source for an error


OK, so i connected the device to my pc and was able to controll it :slight_smile: thanks for the tip @chrode
Now I know that the connections etc are OK.

Thats great, but I want to make it a part of the network, so i got to configure this with a fixed ip right?

Whatever I do, i can’t seem to control this over the standard ethernet network, only peer to peer over multicast.

You don’t need a fixed IP, but it can make things easier.

I would recommend you connect the bridge to your switch and check if the device shows up in your network (f.e. Router log). If so, you have to make sure that openHAB and the bridge are in the same subnet. If openHAB has set the local address for the bridge thing it should work.

If it not shows up in your Network check the blink codes of the bridge. You can select different settings by pressing the button for a defined time.(see instructions)

1 Like

Strange, I’m in a 192.168.0.x network with a sunet mask, no no fancy network here for the moment.
The device has ip and i can ping it and visit the web interface but it doesn’t show up in my device list in my router.
The Blink code is 2 flahes what means static ip mode as i configured.

try dhcp and see what happens