AeonLabs MicroSwitch, status external switch?

I have set up a AeonLabs MicroSwitch, and it seems to work perfectly. But when i change state with my external switch connected to the device i get no status update in OpenHAB. I can’t find any working example setup for this, How can i solve this?



Use habmin and change device parameter 80 to “Basic CC Report sent”, then the device should notify the controller about “external” updates. You should also make sure you have the item defined with: respond_to_basic=true.
Something like:
Switch mySwitch { zwave=“11:command=switch_binary,respond_to_basic=true” }

This works for me with the Aeonlabs (smart) microswitches

Thank you for your answer!
I tried your configuration, and i think it is the right track! But i only get the updated status when i update and save the .item file. It is not updated manually, just when it refreshing the model…

I’m really stucked here. When i restart OpenHab i get the updated status. It seems that the switch not report it automaticaly. I have tried every parameter that i think has with this to do, but with out any result. Please, help someone!

Can you post the XML file for this device (from /etc/zwave)…

Here is the file, thank you!

node3.xml (4.0 KB)

Add your controller (likely node #1) as a member of association group (there are two, try the first one if won’t work, the second one) using HABmin.

That solved it! I have the “Target for automatic reports” as a member. Now i also set the "Target for automatic meter reports to a meber. I thought that the last alternative only was for the energy meter. Thanks!