Aeotec Door Sensor is not seen (sort of)


I have an Aeotec Door Sensor, 2nd Edition that I cannot seem to get recognized by OpenHAB 1.7. I do have other Z-wave components as well as the Aeotec multi-sensor that are all connected.

I have gone through the steps of adding the door sensor to my Aeon Labs Z-wave stick. As far as I can tell, it is connected, the light stays on, etc and the node does appear in Habmin.

TheKorn was very helpful to me in explaining about assigning an Association Group to it. But when I look at Habmin, I don’t see the ability to select an Association Group.

I have these entries in my ITEMS file:
Contact Door_Sensor “Front Door [MAP(]” (gSensor) { zwave=“23:command=basic,respond_to_basic=true” }
Number Door_Sensor_Battery “Front Door - battery [%d %%]” (gSensor) { zwave=“23:command=battery” }

How can I get the door sensor recognized?

Thank you.

Currently the device isn’t properly initialised - you need to wake it up a few times so that openhab can talk to it. Until it’s initialised, and the binding can work out what the device is, you won’t get a list of configuration parameters or association groups.

Whoa, completely missed your reply in that other thread - apologies!

To tag onto what Chris is saying, here’s what I’d recommend doing… grab the sensor off the wall/door. The light will probably be on at this point. Hold down the rear button and walk to your z stick. When you get there, release the rear button, then triple click the rear button. That will wake up the sensor and should cause it to complete initialization. Then reload your browser with habmin, and you should be able to set the association…

…but you’re not quite done yet. Though the documentation says the sensor will be awake for ten minutes, I’ve found that it doesn’t really work. So after you set the association, triple click the back to put it to sleep, wait a few seconds, then triple click it again to wake it up again. It’s a bit of a pain (first world problems! :smile:), but luckily you only really have to do it when you change the settings on the sensor, which is usually never once you get it working.

Please, don’t apologize. I am so grateful for the help that you and so many others give freely on this forum.

It’s funny, I thought I had done the triple-clicking, but I guess not. I have followed your directions and Habin now sees the sensor and I can select the Association Group for it.

While it sees it now (thank you!) I still need to get it to notice when the door opens and closes. But I haven’t worked on that yet… other priorities and life got in the way. :slight_smile: I hope to work on that tonight.

Again, thank you so much for all your help and taking the time to write out specific instructions on getting this to work. I really appreciate it!

np, happy to help. Suggest you run put openhab in debug mode when you get around to testing it, specifically the zwave binding. That’ll let you know what the binding is seeing. i.e. figure out if this is a ‘not getting a message at all’ problem or a ‘not doing the right thing with the received message’ problem. Suspect the latter, which would be good!

I’ve searched for running OpenHab in Debug mode before, but I haven’t found clear instructions on doing that.

Would you know of where I can find clear steps to put OpenHab in Debug mode?

Thank you.

Instead of running (or start.bat on windows), run .

But before you do, read the section on logging.