Aeotec Energy Meter showing as Unknown Device


I am trying to add a Aeotec Energy Meter Uk version to my Z Wave network in OpenHab but once discovered the device is showing as online but underneath in Things it states ‘Unknown Device’. I have tried pressing the pairing button again on the device; removed it from OpenHab and re-added it but it is still showing as an Unknown Device. I am running OpenHab 3.2.0.

Any ideas?


Have you checked the zwave database? OpenSmartHouse Z-Wave Device Database

Gah!!! I can’t see it listed but I was sure doing a Google search I did see this product used by other OpenHab users. Confused!! :thinking:

There are many versions of this device in the database.

What is the device type and ID, and version properties showing in OH? Without this it’s impossible to say if your version is available or not.

We need these (0082:6015:0200::2.0) <–Not these exactly, but the same pattern. Do you see anything like that?


edit: This is the closest match, but it depends on your numbers.

The fact that the properties are not listed means that the binding is likely not communicating at all since these properties are some of the first to be retrieved from the device.

I would probably suggest at this point to either move the device closer, and then reinitialise, or exclude and reinclude.

ok cheers. but how close does the device need to be to the Z Wave controller. Its around 6 meters away. Annoyingly its powered and wired into a switch off the consumer box so you can’t move it closer and the only option is to physically move the Pi closer. Other Z wave devices which battery powered are at the same range if not longer and they paired o.k.

If there’s nothing between the device and the controller, that’s likely to be fine. If theres a brick wall, it may not be - it’s hard to say with no information.

Sorry - I’m just making suggestions here. All I can say is that it appears to be a communications issue. Either the device isn’t communicating, or the inclusion was not successful.

Thanks for your replies and suggestions. Yes I found a very long extension cable and managed to get the Pi virtually next to the Energy meter device, deleted it and re-added it and its automatically found it this time. So distance was definitely the problem.

ok I assumed it was all sorted and good to go!! but when I check the channels and try to adda new one im not able to get any data from the device as it stating NULL. Has anyone managed to get this Aeotec Energy Meter up and running with OpenHab? I assumed I would start gettting data back from it but so far its not going to plan! :-1:

How long have you waited and what are the parameters set at for reporting?


There are a number of versions of this device and I don’t know what you have, but yes, people do use these quite a lot.

oh its now reporting values this morning but it took a good several hours. just curious why it took that long? especially as its mains powered - not on battery.

Tough to speculate without more information.

Parameters 111-113 set the frequency of the reports in 101-103. Also parameter 3 can suppress all reports if the thresholds in 4-11 are not met.

Also since there was a communication problem on initialization, possibly with the “heal” (assuming you did that) a more stable route was found or a route was just found in the normal business of zwave trying to get a message through.

Battery or mains powered not relevant IMO.