Aeotec microswitch 2 with touch panel working as momentary switch

Hi everyone,

I just finished installing the above mentioned devices but for some reason the touch panel is only working as a momentary switch. have changed the setting in openhab for external button mode to 2 state switch mode but still only working as a momentary switch.

anyone has experience with this ?

Also am having trouble setting up the items and site map. this is what i have so far.
Switch item=Smart6 label=“Button Switch” mappings=[ “1”=“ON”, “0”=“OFF” ]

//Aeotec Smart microswitch
Switch Smart6 “Smart6 outlet” (ALL,outlet) {zwave=“6:command=switch_binary”}

Not sure about the device config, but your mappings are wrong - you have a Switch item, which has two valid states ON or OFF. So your sitemap mappings should be something like [ON=“ON”, OFF=“OFF”]. A switch will never have a state of “1” or “0”.

thanks that allows me to control the switch from openhab. much appreciated.

still dunno why it is acting as a momentary switch.

Problem solved. Reset the switch which fixed the problem.


do you know how i can read the state of the switch. right now it only shows the last state from openhab so if someone uses the physical switch, the state does not change in openhab.

Look on the Habmin WIKI for details about device associations - sounds like these have not been setup correctly so openHAB is never notified of any state changes locally at the device.

I have selected the controller to be a member for the “Target for automatic reports” but it still shows up 0 of 5 members at the top. although when I did the same process for “target for automatic meter reports” it shows as 1 of 5 members.

sorry if i did not understand your correctly.

thanks for your reply ben, you pointed me in the right direction. the setting I needed was under configuration parameter, “notification on status change”

Glad you got it sorted!