Aeotec Multisensor 6 - Poor battery life?

Hey Guys,

Struggling with poor battery life here with the Aeotec MS 6, am getting around a week on fresh batteries :frowning:

Have done a bit of reading and thought I found the problem when coming across this discussion. Since I had initially set this device up using USB power I was excited and thought removing and then re-adding while on batteries would solve my problem but nope still only getting about a week.

Habmin settings are pretty much default.
I haven’t done any firmware updates to the sensor- could this be a problem?

However i am using it in a high traffic area (kitchen)- could this be the reason for the low battery life? Since it wakes up very often?

Anyone else experienced this issue?

Sam

1 Like

Sorry to say, but that’s a well-known issue. You can try tweaking it a bit (reduce sensitivity, report intervals etc.), but in the end and if still possible, better switch to permanent USB power.

Thanks for the response Markus, I suspect this. I guess the advertised 24 month battery life is if the sensor reports once per day lol.

Did you try reducing the wake up interval?
Mine (though a Fibaro motion sensor) is set to 7200 seconds, so it wakes up every two hours and has a battery level of 80% after one year of operation.
Note that the wake up interval has nothing to do with the sensor reporting it’s motion state!

I agree that the Fibaro runs for a long time (both the door sensors and the motion sensor has lasted well over a year). The wakeup period probably won’t make too much difference so long as it’s not set to 1 minute or something short like that. I personally use 1 hour, and I think the difference between 1 and 2 hours will not make a huge difference in battery life.

Some time back I did an analyses of battery life. The values below won’t be 100% accurate for many reasons, but it should provide an indicative idea of what settings can impact life (so the basic assumption is that the design is good to start with!).

This shows that a 5 minute wakeup will be significantly shorter life than 1 hour, but 1 hour wakeup to 1 day doesn’t make so much difference.

The other thing that is shown in this table is receive duration - this can’t be adjusted, but if I remember correctly it’s set to 1 second in the binding.

Hmmm - this is probably your problem. If you swap from USB to battery power, then you MUST exclude the device from the network and add it back with the device powered with batteries. Otherwise the device will continue to operate as though it was running on USB power and this (very likely) means that it is permenantly receiving.

the wakeup interval is set to 3600.
where is your sensor located? how many times a day would it update on motion detection?

I understand, but if the sensor is sending updates on detection of motion every few seconds wouldn’t this in effect be the same thing as waking up every few seconds? It would need energy to transmit the change in motion state.
The sensor is in the kitchen and when someone is in the kitchen say cooking over the course of say1-2 hours the sensor could send 20+ updates? Actually no idea how many updates it would send over the course of constant motion over 2 hours as I’m not sure how this works, apart from the 240 seconds timeout.

I did find this in a previous conversation and I excluded from the controller, renamed the xml and then included (with batteries) and re-initialised but this still didn’t fix the problem. Does the actual sensor need to be reset to factory defaults or something?

Not exactly. When the device is ‘awake’ there’s a lot more circuitry powered. When it sends notifications, it ‘just’ activates the transmitter for a very short time. Of course, transmitting is the most power hungry activity, so if you really are sending these notifications “every few seconds” then this really will not help.

My battery calculator reduced the life from ~2 years to ~1 year when transmitting every few seconds. So, clearly it will make a very significant difference. It’s also quite possible that with such regular transmissions the calculation is non-linear so it could be an even larger percentage change (again, I would necessarily read anything into the actual number - just the relative values).

Why not check the log?

I’m not sure - if in doubt, I would reset it to be sure…

1 week is really very short and I would suspect that there is something fundimentally wrong somewhere. I have the Multisensor 5 and it lasted about a year next to my front door, so we’re really talking about a huge difference if you only get 1 week.

I would recommend checking the log if you haven’t already done so to see what is being sent. Using the log viewer on my website should be reasonably useful.

thanks for everyone’s tips. Haven’t given up, taken on some suggestions…

  1. upgraded the firmware- now running 1.7 (this is AU version), this was a challenge and more nerve-racking than anticipated. I used the Aeotec instructions but the firmware wouldn’t work even when the sensor was mains powered. The application was communicating to the sensor but it wouldn’t upgrade and was behaving generally wierd. tried to exclude and re-include to the zwave network still no luck. I then tried a factory reset and re-included and bang the upgrade worked!
  2. When FW upgrade complete I again removed from the zwave network and went back to batteries and then factory reset again. then I included on the zwave network again.
  3. Sensor config is standard apart from the motion sens set to 4.
  4. Zwave logging has now also been enabled- (totally recommend this, much easier to view)

so, since all this the sensor appears to be behaving better even though I’m running on batts. battery level hasn’t changed in 3 days will continue to monitor and update you guys.

Good luck :innocent:

Hello Sam

I’m very interessted at this problem, because I like this sensors and plan to use them in my new project.
How is the battery draining now?

@chris will OH2 support a firmware upgrade?

Regards
Michael

It’s on the ToDo list, but it’s not high priority.

Hey Chris, thank you for information. Do you think, OH2 will be completed within the next 5 month?

Firstly, software is ‘never’ completed ;).

However, I’m not sure what the release schedule is for OH2 - you’d need to ask @kai.

Please excuse my indistinct formulation. I meant, when is OH2 RTM :stuck_out_tongue:
I hope, @Kai could light up a little bit.

Almost been a month and the batteries are still at 100%, and importantly the sensor hasn’t missed a beat since following the procedure above. But as Chris suggested the problem was probably related to me using it on mains and then switching to batteries…(plus there may have been some corruption)

I believe it’s a popular sensor so you should be right with support if you decide to use.

goodluck

@aussie
This sounds well. Because of its recessor I think I’ll plan with them.

Let me know, if something is changing…
Good work, I’m glad that you have not abandoned.

regards
Michael

So I’ve had 2 of these installed for 3 months, and suddenly one just died (on batteries).

However, in Open Zwave Control Panel, the battery is still reporting 100% for the second device, and I’ve never seen the device that has died under 100% either.

The unit stopped working, i put it on USB and it worked, then switched out both batteries for new ones and it works, had anyone else had this issue?

I really want these devices to work and be reliable, I’ve bought recessors already but not yet cut them in, having second thoughts!

I have the same problem. I’m on my fourth set of batteries in the last 5 months. I am not quite sure why, but it will be working fine for about a month, battery stays at 100%, then all of a sudden, dead. I am not sure of the best way to get to the root cause. I am wondering if I need to keep zwave DEBUG fully enabled, then as soon as it dies see if I can find anything fishy in the logs…

Wondering if it’s possible it’s getting stuck in a state where it’s trying to communicate too frequently, ie configuration update on openhab restart or something weird like that, then just drains all the battery.

Anyone else have similar issues or know of a good way to troubleshoot this issue?

I was thinking of creating a ticket with Aeotec soon, see if they can offer any guidance. I’ve already updated

Same issue here.
Have been in dialog with Aeotec for a while, with no results.