AEOTEC NanoMote-Quad (european version) not in database

just got this device a few days back. It has just recently started selling in Europe. I guess the US version of the device is already in the database, the european model seems missing.
Model: ZWA003-C

2019-10-11 16:33:10.081 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 100: Device discovery completed
2019-10-11 16:33:10.087 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 100: Device discovery could not resolve to a thingType! 0371:0002:0003::1.2

An XML file has not yet been created on my openhab system for the device.
Can one of the experts please help by adding the device to the db.
(complete debug-log of the inclusion process is available)

The device has not been fully discovered then. The xml file is really the best, safest way of adding a device to the database, along with an electronic copy of the manual. If the manual indicates it is the same as an existing device, the IDs can be added t that one.

If you wish to add it, the process is documented here.

Wake it up please:

Enable Wakeup:

Press and hold button (any button) for 5 seconds or until LED turns to a green color

LED will change from:

Green //at 5 seconds.
1 Like

here is the XML file. Any help with adding the device to the db is appreciatednetwork_dd419481__node_103.xml (10.8 KB)


1 Like

excellent, thank you.
one question: the device supports S2 security (I like to use it with S0 with Openhab for now) , the database entry says “Supports Security = NO” - is this correct?

I need to wait a few days for Chris to add it to the bundle, correct?

The zwave binding does not yet support S2.

1 Like

correct, but it does support S0 - and this is what I like to use

Then follow the steps to include it securely.
Make sure you include the device through the binding and initialization takes place within 15 seconds…

1 Like

I can not find the latest ZWAVE snapshot build anymore.
when I click on the latest build, nothings is there …

You can also find it here:

after loading the latest snapshot release, then deleting and rediscovering the thing, I still get the same error. then deleted it from the controller and factory reset - new trial, same error:

2019-10-20 15:53:49.945 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 110: Device discovery could not resolve to a thingType! 0371:0002:0003::1.2

2019-10-20 15:54:04.763 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 110: Unable to find thing type (0371:0002:0003:1.2)

does the binding include the database update yet?

just had a look into the XML file of the device in the JAR file - it says …

      <property name="manufacturerId">0371</property>
      <property name="manufacturerRef">0102:0003</property>

The error & xml file do not match.
The error says

which is equivalent to xml

  <property name="manufacturerId">0371</property>
  <property name="manufacturerRef">0002:0003</property>

Your XML is equivalent to (0371:0102:0003:1.2)

This ist what I mean . My error says that the European version of the device is not found. I looked into the XML file that is part of the new JAR download and it looks like it does not include the European version of the device. Sihui added it to the database already. So my question is: has the updated database not yet been included in the binding?

When was the change made? Normally I do a database update each weekend so if the device is added to the database during the week, it will be added to the binding at the weekend.

From the comment from @sihui above, the change was done about 7 days ago. I downloaded the Jar file on Oct 20.

14th of Oct, 7:34PM (approved)

1 Like

Device was included in latest JAR from Oct 23rd and is working correctly now. Thanks for your support.