Aeotec Power Meter Setup with openHAB Issues

Hello! Brand new openHAB user, I just downloaded it and got it installed a couple hours ago. I am using it for one purpose, to monitor power consumption at the mains, to settle a dispute with my landlord.

Anyway, I got the Aeotec Z-wave Gen5 USB “hub” off Amazon, and the Aeotec by Aeon Labs ZW095 ZW095-A Home Energy Meter Gen5. I am running openHAB 2.4.0 on my Lenovo laptop running the latest Linux Xubuntu.

openHAB setup went fine, once I looked up some tutorials on YouTube. However I am having trouble getting readings from the power meter. I enabled (right termonolgy?) the “Electric meter (kWh)” cause I need to know the kilowatt hours used. I tried linking (using default parameters except for the name and Dimension) using every form of Electric* dimension, and every single one says -0.3. It started at -0.1, so perhaps its reading negative? Did I switch up my leads on the power meter?

I hope this post doesn’t violate any rules, I don’t know what y’all need to help me out. I tried to include as much info as I can. I searched Google/YouTube for how to get this meter setup in openHAB and have had no luck. TIA!


So you need to look at the settings that potentially only send reports when there is a certain change in value or time. I assume you just want it to report all vales every X min? Looking at the spec 101 and 111.

Thanks. I’m new here and not sure what you mean by spec 101 and 111. Is that a Section in the documentation or something?

No, that are zwave configuration parameters.
You can find those either in your device manual or in the zwave database:

Easiest and recommended way to change the parameters is HABmin, click the Thing tab, click “Configuration parameters”.

Let’s back up and slow down a bit.

openHAB installation went fine. Good, first step is good. There are a whole bunch of steps between openHAB installation and where you appear to be now. It would be informative to tell us what steps you took so we can see if you may have skipped one or did something slightly off. OH is quite unforgiving in some respects.

The steps you should have done are:

  1. Join the power meter to your USB controller. With the Aeotec you can take the controller to the meter, press the button on the controller, press the button on the receiver, lights will flash and it will have joined the network. But be aware that zwave has limited range and expects there to be a mesh network of a bunch of devices. And when you include the device to your controller it uses the signal strength based on how close they are together. Consequently if you followed the steps above and this is your only device in your zwave network it might have configured itself to use too low of a signal to communicate with the controller. I believe this can be addressed using a network heal, which you can do from Habmin. The developer of the binding recommends always including devices to the controller insitu for this reason. This is done by clicking the scan icon in PaperUI and choosing zwave from the list. Then pressing the button on the device. Then the controller will know how far away the device is and therefore the needed signal strength required to reach it.

  2. Install the zwave binding.

  3. Manually create a Thing for the Zwave controller, selecting the proper /dev/tty*.

  4. Open the Inbox and wait, or initiate a scan for zwave. Any device that has been joined to this controller will show up as a new Thing in the Inbox. Since this is a mains powered device, the zwave binding should figure it out immediately what it is. This is not always the case with battery powered devices.

  5. Click on the entry in the Inbox and you will now have a Thing that represents the power meter. If you bring it up in PaperUI it should looks something like:

Each of those blue dots represents a separate Channel .The ones with the white dot in the center shows that the Channel has been linked to an Item. If you have “Simple Mode” turned on (which will depend on what “package” you chose when you first brought up the dashboard) all of the Channels will show the white dot for all the Channels because OH will have automatically created Items for each Channel for you. The name of the Item will be the name of the Channel with the : replaced with _. For example zwave_device_dongle_node7_meter_reset.

If you don’t have simple mode turned on, you need to create the Items manually and then Link the Items to the Channels you care about.

Did you do all of the above as I described?

Look at the Channels screenshot I have above. It consists of three lines of text. The first line is the human readable name of the Channel. The second line is the Channel ID used for linking to Items. The third line is what type of Item must be used to link to that Channel. This last line will tell you how to define your Items. If there is not a “:unit” after the Item type then the binding doesn’t support Units of Measure.

Notice how, for example, the Electric meter (kWh) Channel says just Number for the third line, not Number:Energy. Therefore no units of measure are being used. The Channels above come from the 2nd Gen version of this same energy meter. So it is likely that the 5th gen looks similar and doesn’t use units of measure.

If I’m reading correctly, the OP has the power meter connected properly and is receiving data from it. He is asking why the values received are negative. I’ve noticed the same as all power readings I receive by default are negative.

The documentation talks about positive/negative Wattage when describing Parameter 2: Energy detection mode, yet the only options provided for selection are Enabled/Disabled.

@Blenderite The idea behind negative values is that you are consuming energy. You have a negative balance until you pay the electric company :slight_smile: In installations where you have your own power source (solar, wind, etc.) there are times when your Wattage is positive. That’s when you are producing more than consuming and you are pushing energy to the grid instead of pulling. In that case, you want to know your net Wattage as that’s the amount you truly took off the grid. For most of people, you simply want this value as a positive value as you won’t be generating any energy.

The question is: how to set Parameter 2 if the UI only gives two, seemingly boolean options?

I forgot to point out, @Blenderite, in your case, set Parameter 2 to “Disabled” as this sets it to 0 = report Wattage and the absolute KWH value (default)

I guess who ever set up this device in the database just forgot to add those options. I’ve added the missing options, those will be available in one of the next zwave snapshot bindings.

1 Like

I know this is a super old thread but your explanation of reading negative because you’re pulling power is wrong. The negative values occur when you have the terminals the wrong direction. I want to be clear, not the wrong terminals but the wrong direction. If you flip one see what happens. If they’re not in the right direction the system can’t show positive and negative values, for example I have solar, so during a sunny day I’ll see negative but positive when consuming more than I’m producing. When the the clamps are wrong direction this will always show negative or positive but not switch between them appropriately