Aeotec Siren Gen5

Im unable to change the configuration properties of this siren. the "save" button is dark instead of white, whats wrong. I can successfully change properties of all my other items.

Same issue on my openhab installation.
The problem seems to be that the form is equipped with an input validity checker.
And obviously, the check for the first input field (5: Primary Notification Sound) is done in some invalid way.
If you click into the first field you see the info hint: “Maximum allowed number is 0”
Howerver, if you change the value to 0, you will see another info hint: “Minimum allowed number is 1”.
If you remove the value, the save-button will highlight again. However, If you then press the save-button, you’ll frist receive a “Thing updated” but subsequently a “400 - Bad request” message.

Actually, I don’t doubt that number 5 is a valide parameter. I did not find it in the documentation of that siren.
I think, the only way to configure that siren to another sound currently is to do it via config/thing/items files. Unforunately I currently only got it working to switch the siren on and off, but not to configure it to another sound or volume…

Looking into the database entry for this product, I cannot find the parameter “5 - Primary Notification Sound” anywhere in it:

But I also do not see that this database entry has been updated to a newer version.

Yet I’m wondering about the timestamps at the bottom of that page, saying that the timestamp of last update was before the timestamp of first added…

In OpenHab1 there was a way to do configuration of Z-Wave components via Items:

However, I cannot find a guide on how to do that in OpenHab2.
I’m not sure if you somehow have to introduce individual channels for that configuration parameters (which already exists in the z-wave database)…

@hr3: Thank you. But that’s the documentation for the old OpenHab1 Z-Wave binding, isn’t it?
Does that still work with the latest OpenHab2 Z-Wave binding?

The first link ist the OH-2.3 documentation for the 1.x bindung, the second for the 2.x binding.

Please refer to the database guide. You need to add a new channel for any parameters that need to be configured in rules since OH doesn’t provide an specific way to change configuration in rules.

@hr3: Ah, OK. Didn’t know that the old binding can still be installed.
How can I install it? In my Paper UI only the 2.2.0 version is being found.

Apart from that, I already found these documentation before, but I cannot find a description on how to set device configuration programmatically via config/things/items files. (Since the way via Paper UI is obviously currently not working at the moment…)

It isn’t in the database. I don’t know what this very old post refered to as parameter 5 doesnt appear to be in the manual either. If there are missing parameters etc then please feel free to update the database.

The “First added” data is probably wrong - this is something I’m trying to backfill and it’s not complete yet.

@chris: Thanks a lot for the quick response.
So, the parameter are already defined in the database entry, but the corresponding channels still need to be defined, right?
Where did the Paper UI get the information on Parameter “5 - Primary Notifcation” from?

I don’t know. There are some parameters defined - I don’t know if these are all parameters. I’ve just not checked.

If you want some defined for use in rules, then they need to be added. Please only add channels that are really necessary - I don’t want to have channels for every parameter as it will be a mess for everyone.

As I said above, I don’t know what this image is of. It’s an old post - maybe the database was updated to remove the incorrect parameter. Maybe the user posted an image of the wrong device? I just don’t know - sorry. Does it really matter though? Surely all you want is a correct database entry now?

I just rechecked the config site in PaperUI for that Siren. something has changed, I don`t know when and how but it is now possible to change the siren sound and volume:


thanks to @kleintody to remind me to that Siren. my plan was to use the Siren, beside its general intention to be an Alarmsignal, to also act as doorbell when I am working behind the house where I can´t hear the indoor doorbell. for that usecase I wanted to change the type of sound and lower the volume to a “normal” value. I´ll check if I can use rules to change the properties of a device via the zwave binding…

Surely all you want is a correct database entry now?

Well… Basically, all I want is to be able to configure the sound via OpenHab.
For me any way is fine. In the Item configuration via Paper UI (as seen in the screenshot) or programmatically via config/things/items file. (But the latter one would be better, because I would be able to integrate a selector in my sitemap)
Right now, I’m not able to set this value, since the first config entry has a broken input check.

@powerpolly: Thank you for that information. What did you do? Did you update your whole openhab installation?

Yes, but we don’t care about when the database was changed, or why there was previously a parameter 5. We just need to make it correct now.

If the database is incorrect, then it would be good if someone can update it. I don’t personally have the time to do this for every device, so it’s really appreciated if others can also help (I normally spend 2 to 4 hours a week working on the database).

@chris That’s absolutely comprehensible. You shouldn’t have to implement all the user requests, but instead being supported by corresponding submissions of the users.
It’s just that I didn’t have extracted from your answers that the wrong form input actually was due to the database entry. (I wasn’t sure if the dialog was being generated just from the db entry or based on something else).

I’ll try to read the documentation on how the update regarding this parameter as an additional channel is to be done.

The data normally only comes from the database, so probably the database changed. I don’t know - there is limited reference in the original post so I don’t know the configuration at that time, but as I said, I really don’t think it matters. We should just try and get the database correct and then the UI should be correct.

most probably yes, I started with 2.2 (and had that Siren from the beginning) and somewhen switched to 2.3…

OK. I can acknowledge this.
I have also an OpenHab 2.2 installed, which showed the same problem.
I didn’t want to uprgade the whole system right now, but just tried a newer version of the Z-Wave binding. With the current version 2.4, the UI is fixed.

Did you get this working ok in the end. I am wanting to trigger the siren to alert me that a door has been opened. Readiing your posts it would be nice to have it also act as an alarm at night with maybe a different tone ?

If you did get it working and there are any special setup instructions it would be good. I have the same make z-wave usb stick on a Pi and a door sensor from them as well. Its all working - just need some form of audible alarm.