Aeotec Smart Switch 6 (ZW096)

Hi All!

Running Debian Stable + Openhab2 stable.

I have a Aeotec Smart Switch 6 (ZW096) that i’m trying to customise the colour on (set by a rule).

The Smart Switch is otherwise working (I can turn it off/on - read power etc).

In my items I have this (channel copied/pasted from paperui):

Color Smart6_Color NewSwitch_HSB “Colour” {channel=“zwave:device:8c3863ad:node2:color_color”}

in my rules I have this:

rule "Motion started Happened"
Item MS6_Study1_Alarm changed from OFF to ON
var HSBType lightred = new HSBType(“0,100,100”)

When I trigger the rule in the logs I see this:

2017-06-05 18:57:38.607 [ItemStateChangedEvent ] - MS6_Study1_Alarm changed from OFF to ON
2017-06-05 18:57:38.629 [ItemCommandEvent ] - Item ‘Smart6_Color’ received command 0,100,100
2017-06-05 18:57:38.639 [ItemStateChangedEvent ] - Smart6_Color changed from NULL to 0,100,100

No change in colour on the device. I can change the colour via openzwave control

Many thanks for any suggestions!

Hi All,

I had an extra item in the definition of items - it should read like this:
Color Smart6_Color “Colour” {channel=“zwave:device:8c3863ad:node2:color_color”}

All working now!

Out of interest, what config settings did you use to read power? I find power reading has the most enormous time lag - measured in minutes rather than seconds.

Power reporting is absolutely responsive and immediately if you set parameter 90 to enabled and parameters 91 and 92 to suitable values:

It is the most responsive Zwave power reporting device I found so far.

It updates every 10 minutes, unless there is a % jump in power usage (so below is me turning a monitor off and on - updating every second!)

2017-06-05 20:03:01.625 [ItemStateChangedEvent ] - zwave_device_8c3863ad_node2_meter_watts changed from 259.82 to 305.655
2017-06-05 20:03:02.619 [ItemStateChangedEvent ] - zwave_device_8c3863ad_node2_meter_watts changed from 305.655 to 341.673
2017-06-05 20:03:03.620 [ItemStateChangedEvent ] - zwave_device_8c3863ad_node2_meter_watts changed from 341.673 to 362.632

I think it is worth looking at the parameters (90, 91-92).

The only thing that I am having problems with is changing the brightness when it is in night-light mode (it is easy to change when in energy mode…) I can change it with the openzwave control panel, but not via openhab2. Need to dig further on this.


Thanks, I’m struggling to get quick updates, even when I have parameter 91 and 92 each set to 1…