Aeotec TriSensor (ZWA005) motion not working

No - that will not make any difference.

I think I see a bug in the binding. This sensor, or at least the way you are waking it up, doesn’t send the WAKEUP_NOTIFICATION message and that is causing a problem. The binding can also use the NIF as a wakeup, but this appears to have a small issue here I think.

How are you waking up the device?

1 Like

I would like to thank you for your help. Finally, I have solved the problem. I concentrated on waking up the device as you mentioned.

When I pushed the action button at least 2 seconds there was no reaction (this is the reason why the previous log did not contain WAKEUP_NOTIFICATION message). So I decided to try to heal the device (from HABmin) after that I again used the action button in wakingup mode and I noticed that the device started communicate with the controller. I had to wake up the device several times but finally
he started initiating transmissions to the controller himself. Now it works without problem.

I think there were the problems with unfinished initialization although in the PaperUI I had online status.
Thank you, once again :slight_smile:

1 Like


I have also made a change to the binding as it should also work when sending the NIF. I didn’t want to merge this last night as I wanted to first understand what you were doing rather than us not being sure. Thanks for confirming - it’s nice to understand the issue, and I’m pretty confident that the fix I’ve made will have eliminated your problem (should someone else have this in future :slight_smile: ).

Hey Lukas_1st,

I’m am struggling with this device also. Openhab does not recognize it. I tried to “wake up” the sensor but had no impact. In your note, you mentioned using HABmin - can you provide background? Also, what exact steps to you use to wake up the sensor? There seems to be conflicting directions on how exactly to do that.

Much information appreciated.

Has your binding fix mentioned above been exported to Github and into OH snapshots?

Yes - I think I saw someone say it had solved the problem as well.

1 Like


Do you still have a problem with the device? I have asked because Chris has made the fix, maybe this is the solution to your problem.
But you mentioned your OpenHab did not recognize the device. I had got different case. My OpenHab recognized the sensor and added it to the network. But the device did not initiate transmission to the controller and did not respond to manually waking up (when I pushed the action button at least 2 seconds).

What I did?

  1. I activated the option ‘heal the device’ in HABmin and short pressed a couple times the action button (the device waked up but it did not send WAKEUP_NOTIFICATION message). Of course, that transmission between controller and device was canceled but after this step I noticed that when I tried to wake up the device normally (it means, pressing the button at least 2 seconds) it finally started transmission.
  2. Then, I waked up the device a couple times and watched the log. I think this sensor needs more time to completed configuration.

After all, it started working properly.

Thanks for this. I’m travelling this week so will only be able to re-try over the weekend.

This helped me too - thanks!

This also helped me too. Had it paired, but would not get motion alerts at first.

What I changed that helped me:

  • Send BASIC_SET to Associated Nodes to Group 2 (not using temp, just motion)
  • Set 0x00 on triggered and 0xFF on clear

Here is a good resource technical I found on the sensor:

Initially, I did also unpair, repair and hit the button (single short press, not 2 second press) at least a few times which seemed to help pick up additional settings.