Aeotec z-stick gen5 and first alert smoke/CO detector - pulling my hair out

Tags: #<Tag:0x00007f6179837f48> #<Tag:0x00007f6179837e58> #<Tag:0x00007f6179837d68>

Hello,
I have an aeotec z-stick gen5 which I’ve installed on a raspberry pi. Openhab2 finds it, but I’m having trouble pairing it with my first device, a first alert combination CO/smoke detector. The stick is changing colors from red, to blue, to yellow, which I understand is normal. According to the manual to the detector, putting the batteries in and holding down the button while sliding in the battery slot should put it into pair mode. I do this after pushing the pair button on the stick, but I cannot get this to work to save my life. I’ve tried all different variations, and I can’t seem to get the stick to pair. I do not get any feedback from the stick that it is in pair mode, either a chirp or a change of color on the LED.

Please help!
jorgy

You have to remove the stick from the RPi to get it into pair mode or you need to go in to PaperUI=>Inbox and search for things. Also, make sure you’ve installed the Zwave binding in Openhab. PaperUI=>Add-Ons=>Bindings.

Ira

NEVER!!! There is NO need to do that, You can put the controller into inclusion mode from openHAB.

Or like I said, you can choose to search for things. I tried to make it clear there were two ways, sorry if I failed. I’ve used both successfully. Sometimes I find it’s not convenient to click Find new things and get to the device in time to put it into pair mode.

Ira

Thanks for the hints here; I was able to get the smoke/CO detectors to pair using the built-in “find new things” right away. It was fairly simple and I liked not having to be in close proximity to the Aeotec stick.

Thanks again,
jorgy