Aeotec Z-Stick gen5 configuration parameter

I’m successfully using an Aeotec Z-Stick gen5 with my rapsperry and everything works as expected.
Now I would like to turn off led notification while the stick is connected to the usb port, but from the habmin panel I cannot set any parameter.
The manual of the stick describe parameter 81 of the serial-api for disabling led notification, how can I set this parameter using openhab ? I can set parameter of my other z-wave devices from habmin but I cannot set any parameter of the z-stick controller.



Currently it’s not possible to set parameters within controllers. This was disabled in the past as sending these commands to older controllers (ie not Gen5) caused the controller to not respond which had a number of unwanted side effects.

I’d not noticed that it was possible to disable the LED. Please can you add an issue into the GitHub issue tracker and I’ll look at adding this (I’d also like to disable it on mine - it’s annoying! :wink:).


Ok thanx, I’ve issued #3075

Thanks - I’ll take a look at this over the next week or so…


1 - Any news about the LED configuration?

2 - i also want to ask if any configuration in this section is necessary or recommended?

No - the LEDs on the controller haven’t been top of the list sorry :wink:.

Yes - as a minimum you should have master set to true unless you also have another controller (eg a Vera or similar).

Ok. OpenHAB is Master = true

What about “Enable SUC Mode” and “Enable soft reset” ?
I’m not sure what function hide behind this points.

Enable soft reset - definitely not as that causes problems with Gen5 sticks.

SUC might help if you have devices that are moving around - it probably doesn’t hurt to set it, but I suspect it won’t make much difference unless you have a network that’s ‘a bit special’.

Okay many thanks so far!