Aeotec ZW132 Dual Nano Switch not sending meter reports

Again (beside my HEM Gen5) another Aeotec device (ZW132) is not sending meter reports like configured all 5 seconds.

Switches of output 1 and 2 are working fine.
When switching from openhab I get strange value sometimes, so switch of one output, and watt in increasing and so on.

Switching from the wall switch, meter send a report once but never updates automaticly.
The only way to get proper results on wattage is to use a rule and refresh all 10 secs.

Current configuration is like this (but I tried nearly all combinations):

  • Group 1 notification (80) = Send Basic CC report
  • Group 3 and 4 (81/82) = send nothing
  • Parameter 90 = disabled
  • Parameter 101 = Send Meter report (w)
  • Parameter 111 = 5 secs
  • Lifeline: Controller

By the way parameter 101 can only be set to “one” option, should it not be possible to choose multiple option by adding the values (like 1+2+4 = 7) ?

Seems to my I have no luck with these Aeotec devices, think I will switch to another manufacturer for my next devices, or do I only have an configuration issues which I (as a newbie) will not see ?

Anyone can help here ?

thanks in advance
Peter

What are you seeing in the debug logs? What version of the binding are you using?

I’m surprised that you need a rule - are you saying that the binding is not polling then even if you set the poll rate higher? That may indicate that the device has not initialised properly, but I’m really just speculating without seeing the log.

Hi chris,

I’m using binding version: 2.5.1.202001070048 (because of my ABUS Smart Switch which you recently added to the DB, thanks fot that again).
I currently try to find out how to activate the debug log for zwave, searching for the docs.
Is it a good thing to always let these logs enabled or does it takes to much disk space over the time ?
(Only have an RPi with an 16GB SD Card)

It gives me a value al 10 Minutes like configured in the binding polling period (which is the smallest interval I can configure here)

I also facing strange behavior when switching via openhab:

  • Light ist switch on (manually by the wall switch)
  • Watt show 16.5 w (which is ok)
  • Switching off Light from openhab, light goes off, but watt remains at 16.5
  • Swtiching on light from openhab, light goes on, but watt goes from 16.5 to 0

What do you need to see from the logs, changing parameters, or just switching the lights from OH and manually ?

/Peter

It is described toward the bottom of the ZWave binding doc.

The smallest inteval should be 10 or 15 seconds if you want to set it that low (but this is not recommended and the device should send reports rather than set the polling so fast).

In the first instance, let’s just see if it is sending anything. If it’s not, then maybe the associations are not set, or the device is incorrectly configured. If it is, maybe the binding is just not decoding it correctly.

Here is the log file.
I switched both lights on and of multiple times from openhab.

Hope that helpszwave.log (971.3 KB)

The relevant Node is Node ID 7

Thanks.

I thought the problem was updates from the device? ie if you change the device state, then OH doesn’t update? If so, can you provide a log that shows what happens (if anything) when you change the state of the switch - but don’t do anything in OH.

It does not matter from where I switch, manually or via an OH switch.
Main problem is that I don’t get the meter reports every 5 secs as configured.

You should see from the log that when I switch a light to ON, I get a watt change from some value (16.X) to 0 which seems strange to me. As far as I read everything correct from the Log Viewer

Watt metering is the issue.
Getting the ON/OFF state in OH is working fine when usw the manual switch.

hope I could clear up the issue ?

The problem with this log though is there are so many commands being sent that I can’t see what is coming from the meter due to polling, and what is coming unsolicited. The log is 40 seconds long, and in that time you’re sending 10 commands to the switch so the log is just full of events.

I would very strongly recommend not to configure any device to report as fast as every 5 seconds. This might be ok if you only have one or two devices, but it will not scale and for sure you will have big problems in future (but for now at least it’s ok for testing).

Anyway, please can you provide a log showing what is received from the device when you don’t do anything in OH. If there really is nothing, then it’s clearly a configuration issue with the device rather than a bug in the binding.

Ok, just let the log run, but dont switch manually or via OH, right ?

Yep - run for a couple of minutes - change the switch once or twice (say, twice in a 2 minute period when your computer time is around 00 seconds so I can have an idea where to look).

Thanks.

Will do that, but need a way to upload it to a cloud storage as the log will grow above 1024K which I can upload here. There are multiple other devices that report.
What would you recommend as report intervall from such switches (metering data) or power outlet plugs ?

Most devices will allow you to set two parameters for reporting - a period, and a “level”. So it will only report if either the period, or the level are exceeded. I would then set the period reasonably high (eg every few minutes, but the level low - low here will depend on the size of the load.

So, you might set the period to 5 minutes, but the level to 2 watts - if nothing changes because the light is on or off, then the meter checks in every 5 minutes. But as soon as you turn the device on or off, it will change by more than 2 watts, and you instantly get an update.

If the device just has time, then you should have a think about how many devices you have - if you start to overload the controller (and ZWave controllers at the moment do not have fast processors inside) then you will start to see errors showing up in the log. If you only have 5 or 10 devices, maybe 10 seconds is ok (depending on how many reports they send) - if you have 100 devices, then it will be a different story…

Thanks for the explanation, that makes sense to me, will try to configure it like that.

Here is a log of around 4-5mins while I switched OUT2 twice with some time between it.
I also disabled my HEM Gen 5 while capturing log to avoid a lot of log entries.

Hope this help.

Regarding the polling Interval which can be set on the thing, the drop down only allows 10mins as minimum value, but I can other values manuall via HABmin for example, right ?zwave.bak.log (923.6 KB)

Thanks.

What firmware version is the ZW132?

Its 2.2

Thanks.

So in the log I do see state updates coming in from the device -:

So the device is sending notifications to the lifeline (or at least, to one of the association groups). This is resulting in the channel being updated, and therefore should result in the UI being updated.

However, as you have said, there are no meter requests. Given there really is nothing in the log, I think this must be a configuration issue with the device.

What have you configured for parameter 91? According to the manual, this is set to 25W and it will not send an update if there is not a change of this size and I think I saw earlier that the meter readings were about 16W. I would have still expected the device to send readings if you set the duration to a shorter time, but maybe it doesn’t work this way in this device?

91 and 92 are at value: 5
But I disabled threshold by parameter 90, so report should be send at any value right ?

I guess so.

One more thing I’d like to check before I’m out of ideas…

Can you do a complete reinitialisation of the device. In the parameters there is an option called something like “Reinitialise device” - select this and save. It will take a minute or so probably, then send me the log so I can see how things are configured.

Ok, did that, here is the log, but nothing changed from what I can see.

Beside that it not sends metering reports on its own by the defined interval, from the logs I can see for example Switch 1 was on and Watt=16, I turn switch 2 on and it reports watt again at 16w and also that Switch 1 is still ok.
I turn switch 2 off and it reports watt=33 which is a report of watt because Switch 2 was an before and so the 2nd lamp.

So what I tought was, when I turn switch 2 on it send me the new report with 33 watt when both lamps are on, but it is that fast that I get the report of what was “shortly” before or some milliseconds after switching.

This makes sende to me now.
But still it sends no report of its own at the defined interval.

zwave.node7.log (270.7 KB)

Unfortunately the log doesn’t seem to have the initialisation of the device. I don’t even see the configuration command from the UI update.