Aeotec ZW132 switch configuration problem

Hi,

I updated my openHAB installation to 3.3.0. I noticed that the two Aeotec Dual Nano Switch Had the Status ERROR:HANDLER on Main UI. The Thing configuration shows the following for the parameter 101 : Set group 1 reports :

Status: UNINITIALIZED
HANDLER_CONFIGURATION_PENDING
{config_101_4=The value 15 does not match allowed parameter options. Allowed options are: [ParameterOption [value="1", label="Send Meter Report of energy (kWh)"], ParameterOption [value="2", label="Send Meter Report of wattage (W)"], ParameterOption [value="4", label="Send Meter Report of voltage (V)"], ParameterOption [value="8", label="Send Meter Report of current (A)"], ParameterOption [value="256", label="Send Multi Channel Meter Report of wattage (W) C1"], ParameterOption [value="512", label="Send Multi Channel Meter Report of wattage (W) C2"], ParameterOption [value="2048", label="Send Multi Channel Meter Report of energy (kWh) C1"], ParameterOption [value="4096", label="Send Multi Channel Meter Report of energy (kWh) C2"], ParameterOption [value="65536", label="Send Multi Channel Meter Report of voltage (V) C1"], ParameterOption [value="131072", label="Send Multi Channel Meter Report of voltage (V) C2"], ParameterOption [value="524288", label="Send Multi Channel Meter Report of current (A) C1"], ParameterOption [value="1048576", label="Send Multi Channel Meter Report of current (A) C2"]]}

The same happens with parameters 102 and 103. The UI don’t allow to select multiple values for parameters 101, 102 and 103.

Using the tab “code” in the UI you can set any of this parameters, but the binding shows the ERROR:HANDLER message if you specify a number that is the sum of more than one bit flag.
Valid values for the binding in the UI are : 1, 2, 4, 8, 256, 512, 2048, 4096, … but, for example 11 give the ERROR:HANDLER status.

Prior to openHAB 3.3 I had the value 15 for Parameter 101_4 and worked ok.

How can I set this parameter to 15 again in openhab 3.3.0?

Thanks

I fixed this for you, but it will not be available in a binding until reviewed by @chris who is on holiday. For now you can get three of the reports by setting gr 1 to 1; gr 2 to 2; gr 3 to 4. “8” is basically redundant because A = W/V

The parameters 101, 102 & 103 were set up with “Limit to Options” = “true” (red funnel) and that is now changed to “false” (black funnel). That will allow any setting between min and max within one group.

1 Like

Thanks!!

I had configured the thing as you have suggested and it works.

Do I need to update the binding when @chris reviewed your fix? Please let me know how can I get the fix. I wish to configure groups 2 and 3 with other settings when the fix becomes available.

Yes (after approval and incorporation into a new snapshot binding). One approach is to remove the UI zwave binding. Go into the console and feature:install openhab-transport-serial. Then download the snapshot binding from here and put in the addons directory. If you want to keep an UI version you will need to update all of OH to a 3.4 snapshot or milestone that contains the zwave binding update. In either case you may have to delete (not exclude) the thing and rescan to pick up the new properties. Check back in a week or so.

1 Like