Aeotec Zwave Plus unknown ZWA005

Tags: #<Tag:0x00007efecde3db18> #<Tag:0x00007efecde3d870> #<Tag:0x00007efecde3d708>
  • Platform information:
    • Hardware: _Raspberry 4, 8GB + Aeotech 5th gen z-wave stick
    • openHAB version: Openhabian 2.5

Hi to everyone.

I’ve bought a ZWA005 fromw Aeotec, a trisensor.
I follow all the instruction in the small manual and it seems that I paired my sensor to my network.
Now I have to autodiscover my sensor…
My paper UI find it but is an unkown device.

the log says:

Blockquote 2020-11-26 22:22:28.437 [ERROR] [mmandclass.ZWaveSecurityCommandClass] - NODE 12: Error decapsulating security message
java.security.InvalidKeyException: No installed provider supports this key: (null)
at javax.crypto.Cipher.chooseProvider(Cipher.java:896) ~[?:1.8.0_265]
at javax.crypto.Cipher.init(Cipher.java:1252) ~[?:1.8.0_265]
at javax.crypto.Cipher.init(Cipher.java:1189) ~[?:1.8.0_265]
at org.openhab.binding.zwave.internal.protocol.commandclass.ZWaveSecurityCommandClass.generateMAC(ZWaveSecurityCommandClass.java:528) ~[bundleFile:?]
at org.openhab.binding.zwave.internal.protocol.commandclass.ZWaveSecurityCommandClass.getSecurityMessageDecapsulation(ZWaveSecurityCommandClass.java:319) [bundleFile:?]
at org.openhab.binding.zwave.internal.protocol.ZWaveNode.processCommand(ZWaveNode.java:1238) [bundleFile:?]
at org.openhab.binding.zwave.internal.protocol.ZWaveTransactionManager$ZWaveReceiveThread.run(ZWaveTransactionManager.java:532) [bundleFile:?]

Now… I see that this product has the possibility to have a S2 security network. If i understand the log, it ask for a key.
I suppose it is my DSK key… but I have no idea where to put this on my OH2.

Some one has got an Idea?
bye

Welcome!

There are 10 stable versions of openHAB 2.5 (openHABian is only at version 1.6, I think) and some development snapshots. What is the third number on your openHAB version?

If you tried to pair it securely, that is your issue. The security key is part of the openHAB binding.

Now… I see that this product has the possibility to have a S2 security network. If i understand the log, it ask for a key.
I suppose it is my DSK key… but I have no idea where to put this on my OH2.

All S2 security devices must be backward compatible with the older standard. openHAB does not support S2 security but works with S2 devices either unencrypted or with the older security. Since I have no security devices, I run my network unencrypted.

Do you really need secure pairing? Let’s start there. The device is listed in our community maintained database so it should be known my any 2.5 version binding.

Hi Bruce,

OpenHAB 2.5.10-1 (Release build)

I would ask yes… but I don’t know in the manual there is no procedure for the secure pair… there is just the pairing.

No I don’t need (for the moment) the secure pairing, I just need it for control a light.
But from what I see on the Log it seems that the system is in secure mode… (not really sure).

I’ve just follow these instruction: http://manuals-backend.z-wave.info/make.php?lang=en&sku=ZWA005-C&cert=ZC10-18046087&type=mini

And as you can see it say: “If it is the S2 encryption network, please enter the first 5 digits of DSK.”

But If OH2 cannot make a S2 encryption… I don’t know how i did a secure network? O_o’

How did you pair it though? Using the button on the controller?

It is best to include it through openHAB. Battery operated devices tend to not stay awake long enough to be fully discovered by openHAB. Once discovered and identified, it should work though.

I am assuming the device and controller are both the proper ones for your world region. There are several incompatible world regions.

I Paired from my AEOTEC USB Stick… this evening I can try to exclude it and do the pairing from OH2.

The Aeotec 5th gen is for EU market and the sensor the same…

I this moment I have paired 5 device :

  • 3x Heiman Smoke sensor (work)
  • 1x fibaro smart switch (work good)
  • 1x HSP02 motion sensor (work… but is readed as a SM103… not so good…)

I hope that the system is correct for the region at this point.

It works!
Now OH2 recognised the sensor, I cannot find today a signal from the sensor but this is another problem… :slight_smile:

1 Like