Aeotect Nano Dimmer Time Offset

Good morning all,

Is anybody able to advise how to change the “Clock Time Offset” item that’s part of an Aeotect Nano Dimmer (ZW111)? My setup seems to have a value of 60, which seems to trigger my rules early. The rule is set to switch the light off at 23:00, but it triggers at 22:00.

Note the bottom item in the photo below.


I don’t think that this is a problem with the time offset then - that is 1 hour early. The 60 seconds difference in the time really won’t make that big of a difference.

I’m also not really sure why the time in the dimmer impacts the rules at all? You can’t IIRC even read the time - the time offset simply keeps the dimmer time set to within the number of seconds you specify, so that if the dimmer is doing anything automatically, it has the correct time. It is normally only really necessary for devices that support schedules.

Thanks Chris. My confusion for the same number. Didnt realise it was in seconds.

The one thing that may be the culprit is the changing of my timezone after setting up my Things (from Berlin->London). I wonder if I need to remove the item and re-create it within the new timezone? I can confirm that I have done a reboot or two since then.

This item will keep the time on the device set to within X seconds of the time on your computer. So if you computer time is out by 1 hour, then so will the device time. If you change the computer time, the device time ought to update as it will be more than X seconds out (where X seems to be 60 seconds).

Just to come back with a status / fix and close out the thread.

I took a look at my time settings on both the system and in Openhab. Perhaps a quirk of the British time system at fault.

Firstly, running the unix date command pointed out GMT.

$ date 
Thu  7 Jan 21:23:38 GMT 2021

Secondly in Openhab3 >> Regional Setting >> Timezone, I believe the value was set to London… or possibly UTC. I’m not 100% sure if they were aligned.

To fix, I selected the top-most option in the Timezone settings, which was blank. As I understand it, this should then match the system time. A quick reboot later and my offset problem was gone.

Thanks for your help @chris

1 Like