AeotecZW116/ZW139 (Nano switch), not in db

Hi @chris,

I have a ZW116/ZW139 device that’s not recognized by the db, could you please have a look at this?
The ZW116 is already in the db but this seems to be a different version…

I’ve attached the xml and the link for the manual is here.
node79.xml (8.4 KB)

(This is similar to a previous case/node where you helped me, ref: Aeotec ZW111: Incorrect parameters? Version difference?)

Thanks for any help! :slight_smile:

This device is already in the database. Are you using the latest snapshot?

1 Like

Ah, I jumped to a conclusion way too soon, should’ve seen the date the ZW116 was added…

Thank you and sorry! :neutral_face:

No problem at all… :slight_smile:

Hmm, I’m sure I don’t fully understand how this works but I just tried add a ZW116-A to OH2 and get an unknown device. The attributes look somewhat different from what I can see in the device db mentioned above. Namely the Type/ID which is 0103:0074. Is this a different device or am I doing something wrong?

I guess it’s a differnet region - I’ve updated the database and it will be added next time I do a binding update (possibly tomorrow).

Very cool. Thank you. Looking forward to testing it.
Do I have to remove, reset, and add the device?

No - it shouldn’t be needed. Just update the binding and hopefully it will be discovered.

Much appreciated. I tried to find out what the appropriate way is to “update the binding”. Looks like there’s a ton of ways to do it wrong and/or break everything. Please, point me to me to the right location where I can find how to properly update the z-wave binding. Thanks.

If you are using the snapshot version, then simply uninstall the binding using PaperUI, wait 30 seconds, and reinstall it. If you’re not using snapshots, then it’s somewhat more complex, so hopefully you’re on the snapshot build?