After a crash an issue with binding zwave things

A few days ago my raspi experienced a crash, and would not boot up anymore. I had to reinstall openhabian and then restore from the openhab backup files using the “sudo openhab-cli restore”, making sure the right bundles were installed in karaf, the right port set up for the z-stick gen 5 and the works. However, despite all this the thing config list in the habmin would remain greyed out with a question mark. The paperui states that the things are “uninitialized-bridge_uninitialized”. New items would not show up in the inbox either.

So finally, I restored the z-stick. This has changed things a bit so that now the old things are still grayed out, but it is discovering/picking up things in the inbox.

So here’s a question: since I have a fairly large amout of z-wave things, adding them again, setting up channels and so on with right naming convention would be a major pain: is there a way to force openhab/zwave to use the existing thing config - or copy the existing config to the new device ID? For example: the ZW096 Z-wave Smart Switch old id is zwave:device:52b1bacc:node3 and the new one is showing up as zwave:device:622caf76:node3 . So if i could somehow (within internal openhab db I assume?) point the new id to the old config, it would be a real life saver.

Any feedback would be greatly appreciated. :slight_smile:

You have two options:

  1. delete the Zwave stick Thing and while adding it again change the stick id to your old id.
  2. Use Visual Studio Code Editor and change the old id to the new id within seconds

Thank you sihui for your fast response :slight_smile: - one quick question though: in what file should i change the id using the VS Code Editor?



Just change all occurrences of your old controller id:


VSC will open all files (not visible), change the id’s and then saves all files.

Unfortunately it did not work, but thanks for the hints :). I tried the two methods you specified, but still getting the “uninitialized - hadndler configuration pending”. Looks I will need to redo thing association the hard way…