After fresh installation of openhab2 in my raspberry pi,I cannot find Add-ons folder

After fresh installation I cannot find add-ons folder in my raspberry pi!

more info are needed :slight_smile:
which installation did you use? (openhabian or raspbian)
which version of OH2 are you using? with which Java?
which folder are you trying to identify? (/usr/share/openhab2/addons or another?)

yeah i used raspbian os, and OH2 directory is /etc/openhab2

if you want to manually deploy some addons, you need to place them in /usr/share/openhab2/addons folder
this is assuming that you installed using the apt-get method
the /etc/openhab2 folder is for configuration elements

https://docs.openhab.org/installation/linux.html#file-locations

can i manually copy the addons folder from github? will it work?
Actually am looking for bindings for this : org.openhab.io.gpio*
org.openhab.binding.gpio*
overall I want to automate relay board using raspberry pi GPIO pins
here is website i took as reference can you guide me will that procedure work for OH2?

The GPIO Binding is part of the standard OH2 distribution.
You can install it using PaperUI -> Add-Ons -> Bindings -> binding-gpio1

No need to deploy it manually as a *.jar

The (old, since it is using OH1) instruction set that you are following described a manual deployment of openHAB (and associated addons). This is not necessary. You can go the “auto” way and use OH2 :slight_smile:

You can search in this forum for many GPIO examples

check out also: https://docs.openhab.org/addons/bindings/gpio1/readme.html

Yeah its working when I assign GPIO pin,but in user interface when I turn on the switch it doesn’t send any signals to the GPIO by default the relay is turned ON after assigning gpio pin number in demo.items

I am not sure that I understood the issue…

post the item definition to see
did you check the logs to identify any errors?
I don’t use the GPIO binding so I can’t help much with troubleshooting.
Make sure that you have read the doc entry and search the forum for examples also

Here is Item code I have included

yup… I expected this :slight_smile:

you are copy-pasting a mistake from the tutorial

there is a typo there (space missing after RaspiLED)

Switch RaspiLED { gpio="pin:4" }

You need to invest some time to read through the documentation and examples
There is a saying: “I am going slow because I want to move too fast” :slight_smile:

@praveen_kumar

I am going to second @Dim advice here.
Read the docs, and then read the docs again and when you are finished read them again.
All the info you need are in them.

Also avoid copy and pasting code and examples for 2 reasons:

  1. there can be some copy and pasting errors from the browser to your text editor. This can be due to browser settings, locale settings… So you can end up with transformed characters of hidden characters in your text editor and that will create errors.
  2. That’s the main reason. When you write the code yourself, or copying manually, you get to understand and learn the meaning and syntax instead of “blind” copying and pasting. If you intend to use openHAB, you need to learn it. One of the best ways to do that is having a go at writing the configurations and rules yourself. So try to avoid the copy and pasting.

And again, read the docs

2 Likes

For kind information,I have implemented same thing last year but, I lost my device so trying to do it again,please help me out like I have installed GPIO binding and also all required addons but From dashboard when I turn on/off switch its not turning on/off the relay ,by default the relay is turned after I assign some GPIO Pin in demo.items

Hi I ask for help please.
I had to reinsert openhabian 2.5 on my raspberry with openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img and now I can no longer find the “usr \ share \ openhab2 \ addons” folder to put inside the Jar file org.openhab.binding.openwebnet-2.5.0.M4.jar.
the only folder present in my installation is:
“openHAB-userdata \ tmp \ mvn \ org \ openhab \ addons”

what am I doing wrong ??

Thanks Marco