After migration from 3.0 to 3.1, the cards in Main UI don't show the item data

I run OpenHAB in docker on a raspberry pi and just noticed that the cards in Main UI sometimes don’t show the item state anymore.
This worked in OH 3.0, but there seems to be an issue in 3.1?

I have only the “HTTP binding” and the “Dresden Elektronik deCONZ Binding” installed, but problem exists for both bindings.

Please see attached screenshots.

The log file does not show any problems.
What could be the reason for this?

Any help appreciated!

1 Like

#MeToo, only reloading the page helps

I can confirm this. There was once a change because of empty pages when switching to another tab immediately after loading. UnfortunateIy I can’t find the issue anymore. I’m quite sure it did start with this change.

We should create a new issue on Github…and it’s more related to openHAB 3.1 (and 3.2.0.M2)

Reload Browser:


The Android App also seems to be affected by this problem. But you cannot refresh in the Android App.

Did you open an issue in GitHub?

Not yet. I can do it next weekend.

1 Like

I also notice this on Safari on iPhone, iPad and Macbook.
I did not notice it on Chromium on a Raspberry PI which is continuously showing the main UI. I suspect it is related to a browser tab which is not continuously shown.

Yeah, there seems to be a fix in Git :slight_smile:

How can I find out in which build the fix is included?

I have updated to latest snapshot and it works like a charm. Also overview page is starting faster :+1::muscle:

1 Like

I am on openhab 3.1.0 on a raspberry pi v4 and this is always happening in one windows 10 (professional) PC that I do not use often to connect to the main ui. It happens both with chrome and edge. I also tried to clean cache but I am lways unable to see cards or badges. On the other hand, on my android devices and on my home windows 10 (home) PC the main ui shows almost every time the items regularly (rarely a refresh is necessary). Is this behavior possibly related to the issue being described here?

EDIT: if I connect to MyopenHAB (i.e remotely) the mainUI always shows the cards contents in the PC in which it doesn’t work locally.

Could be the same issue. It sounds similar, but strange that you don’t have the issue on all devices.