After oH restart: basicUI icon-format changed from bitmap to vector

hello,
i’m running oH 2.4 now, and (I think also before) after a restart from openHAB the setted default icon-format in the basicUI is changed.
I use some own png files (this works and the png are shown in sitemaps etc. …), but after a restart the icon-format is changed to “vector” again.
(look that also the format in the ClassicUI is changed back to “vector”, but I don’t use the ClassicUI).

Anyone else have this problem?
Any idea how to solve (and please not “use vector …”) ?

Thanks!

Do you have anything changed in runtime.cfg?

Do any other parameters revert to their old value on a restart?

Are you running off of an SD card?

Hello again :wink:

  • In runtime.cfg I changed nothing, there is also no active line (everything is commented out “# …”)

  • Just test it, it seems that also the “Default sitemap” is switched back to “demo” (before I change to my “mHome” sitemap (this is correct, only the name without extention or path)
    Other thinks like “Theme”, “Condensed layout” are not changed back. Works correct.

  • System is booting & running from SSD Harddisk (no Micro-SD in the Raspberry!)

(just tested, “Vector” is active again after oH restart, and demo -sitemap is default (instead my “mHome” )

Did you by chance choose the Demo package when you first installed OH? I don’t know if there is a way to transition off of the demo package without reinstalling and choosing a different package. It might work to change the package in addons.cfg.

Was 3 month ago, and I think, I install also the Demo package.
(is there a log or so to see what was selected?)

However, I thing the fall back to “vector” instead “bitmap” should not happens, sound like a bug or configurtation failure (but where?)).

In the addons.cfg there is only one active line;
remote = true

How can I change the " a different package" ?

Default Sitemap 
demo
The sitemap to show if no parameter is passed.

In the addons.cfg remove the # (comment out) in front of package and change to the package you want then restart OH.

Example for changing to standard:

# Valid options:
#   - minimal  : Installation only with dashboard, but no UIs or other add-ons. Use this for custom setups.
#   - simple   : Setup for using openHAB purely through UIs - you need to expect MANY constraints in functionality!
#   - standard : Default setup for normal users, best for textual setup
#   - expert   : Setup for expert users, especially for people migrating from openHAB 1.x
#   - demo     : A demo setup which includes UIs, a few bindings, config files etc.
#
# See https://www.openhab.org/docs/configuration/packages.html for a detailed explanation of these packages.
#
package = standard

OK, I activate this line with “standard”,
I changed the format to “bitmap” and restart, but still after coming up again is set to “vector”.
Test it twice :frowning:

Any chance to find out the reason (logfile?) and fix? Because after restart lot of bitmaps are missing in the screen (till changemanually back to “bitmap” in the BasicUI …)
Or set it by (i.e.) cron to “bitmap” in a configfile, because the change take effect without restart oH etc.

Can anyone confirm this behavior?

Your’s is the first report of anything like this. I’m not seeing this behavior and it would appear that there are not many if any others who are seeing it either. So I don’t really have much to go on. I know of no logs that would show this happening. It’s very odd behavior which is why I asked about the SD card, as changes to files that revert on a restart is a sign of a failing SD card.

Short of a reinstall of OH from scratch I don’t have any recommendations.