After reboot always problems with all usb sticks

Hi all,

every time after rebooting my raspberry pi I got big issues with all my usb sticks (see below with sticks with corresponding bindings installed). For the zwave stick, I use a Z-Wave Plus USB Stick (ZME_UZB1) stick, for the MaxCul I use a Busware CC1101, for the Lacrosse USB Stick I use a JeeLink usb stick.

The command: ls -l /dev/serial/by-id results in the following:

lrwxrwxrwx 1 root root 13 Mar 12 17:23 usb-0658_0200-if00 -> …/…/ttyACM0 this is the ZWave Stick
lrwxrwxrwx 1 root root 13 Mar 12 17:23 usb-busware.de_CUL868-if00 -> …/…/ttyACM1 this is a MaxCul
lrwxrwxrwx 1 root root 13 Mar 12 17:23 usb-FTDI_FT232R_USB_UART_AI03D96I-if00-port0 -> …/…/ttyUSB0 this is a JeeLink Lacrosse Stick

But all I got in the logfile this (as an example for ZWave):

2018-03-12 17:30:16.715 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Stopped ZWave serial handler

2018-03-12 17:30:16.738 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/ttyACM0'

2018-03-12 17:30:16.750 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is initialized

2018-03-12 17:30:16.754 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - Update networkKey

2018-03-12 17:30:16.758 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller

2018-03-12 17:30:16.762 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.

The ZWave Stick is listed as Offline, as well the Lacrosse items are not updated anymore; MaxCul cannot send commands anymore to the thermostats, which results in the following entry in the logfile

2018-03-12 17:35:00.521 [ERROR] [ing.maxcul.internal.MaxCulMsgHandler] - Not enough credit after waiting. This is bad. Queued command is discarded

Can anyone help me with this?

no one a idea?

I have the same error message when I try to pair the first thermostat. Did you solve your problem?

yeah it is solved! use symlinks! this issue is caused by different usb locations after reboot, and symlinks will solve that.

Can you give me some more Information? How do i use it?

@volcore79 Here’s a guide with all the info. may need to adjust if not using RPI.

Thanks. Great documentation. But I am not able to use the new symlink in OH2. I unplugged every usb device but the MaxCul usb device and use /tty/ACM0 on the beginning. There is no error in openhab.log regarding CUL anymore. But I still see this message “Not enough credit after waiting. This is bad. Queued command is discarded” when I try to set the temperature…

same for me… problem exists since ever. at the moment i try to switch to the eqiva bluetooth radiators from eq3. hopefully, they are more easy in terms of maintenance and set up