After Update to 2.5.0-Snapshot FritzBox Binding shows error

Hello,

I update my openhabian to the latest Snapshot Version. Everything is working bot not Fritzbox-Binding…

Openhab Log shows error:

2019-03-31 23:13:42.347 [ERROR] [nal.common.AbstractInvocationHandler] - An error occurred while calling method 'ThingHandler.handleCommand()' on 'org.openhab.binding.avmfritz.internal.handler.DeviceHandler@5eae72': null

My Fritzbox 7590 Thing is online but all Smart home device are set to “unknown”

I reinstall the binding already, further i delete the fritzbox thing and re-connect it but nothing is working. If I delete some smart home things like the Outlet, the Paper UI cannot find it anymore for reinstall…

somebody any idea? :frowning:

Thank you and BR
Dennis

Has nobody any idea?

May this information are helping for support: This is the full message, which I get…

2019-04-01 08:14:01.070 [ERROR] [nal.common.AbstractInvocationHandler] - An error occurred while calling method 'ThingHandler.handleCommand()' on 'org.openhab.binding.avmfritz.internal.handler.DeviceHandler@16738b4': null

java.lang.NullPointerException: null

	at org.openhab.binding.avmfritz.internal.handler.AVMFritzBaseThingHandler.handleCommand(AVMFritzBaseThingHandler.java:190) ~[?:?]

	at sun.reflect.GeneratedMethodAccessor121.invoke(Unknown Source) ~[?:?]

	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]

	at java.lang.reflect.Method.invoke(Method.java:498) ~[?:?]

	at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect(AbstractInvocationHandler.java:153) [135:org.openhab.core:2.5.0.201903281407]

	at org.eclipse.smarthome.core.internal.common.InvocationHandlerSync.invoke(InvocationHandlerSync.java:59) [135:org.openhab.core:2.5.0.201903281407]

	at com.sun.proxy.$Proxy144.handleCommand(Unknown Source) [242:org.openhab.binding.avmfritz:2.5.0.201903310929]

	at org.eclipse.smarthome.core.thing.internal.profiles.ProfileCallbackImpl.handleCommand(ProfileCallbackImpl.java:75) [185:org.openhab.core.thing:2.5.0.201903281410]

	at org.eclipse.smarthome.core.thing.internal.profiles.SystemDefaultProfile.onCommandFromItem(SystemDefaultProfile.java:49) [185:org.openhab.core.thing:2.5.0.201903281410]

	at sun.reflect.GeneratedMethodAccessor120.invoke(Unknown Source) ~[?:?]

	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]

	at java.lang.reflect.Method.invoke(Method.java:498) ~[?:?]

	at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect(AbstractInvocationHandler.java:153) [135:org.openhab.core:2.5.0.201903281407]

	at org.eclipse.smarthome.core.internal.common.Invocation.call(Invocation.java:53) [135:org.openhab.core:2.5.0.201903281407]

	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]

	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]

	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]

	at java.lang.Thread.run(Thread.java:748) [?:?]

For the moment I tried to install the stable version but this was also not successfull, the snapshot still installed :frowning:

Hi Dennis

As I don’t work with that version, but with M1 build. I cannot fully speak for it. But I also recognized some issues with the AVM binding. I’ve removed it for the time being as it is not mandatory for what I’ doing

Maybe I will have a try and check again. What I see

Regards
Stefan

For my installation it is very important, because the Heat-Controll is the main feature of my openhab.if it not work i can throw away the whole system!

Sh… I understand

Maybe try to use an older version of the Binding. Let’s say the one from OH 2.4 (or even 2.3 if available). I don’t know if it would be possible, but I think it should work.

Regards
Stefan

I never installed any binding without Paper UI how can I install an older version of AVM Fritzbinding?

By the way: This message I get also since I made the update, only … May this error is the cause of my Fritzbox problem? Do you have any Idea how I can solve it?
The other Treads related this error cannot help me.

2019-04-01 09:21:21.811 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007

2019-04-01 09:21:21.830 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-misc-restdocs'

uninstall the existing binding in PaperUI
Put the org.openhab.binding.NAMEofBINDING.jar into the addons folder
i.e. /usr/share/openhab2/addons for instance… but the path my vary depending how you have installed openHAB

check this: https://www.openhab.org/docs/installation/linux.html#file-locations

OK, I installed the Version 2.4.0 but the same result! But before this version was working!

Yes there seems to be something… check also this post:

Cheers
Stefan

Hi Dennis,

Unfortunately the AVM FRITZ!Box Binding is not working in the latest snapshot version (see https://github.com/openhab/openhab2-addons/issues/5341 for more information). It was possible to reproduce your error mentioned in post 3. We are working on a solution. I would suggest to downgrade to OH2.5.M1 - which contains a working binding - until the issue is solved.

Hello,

i downgraded to the last stable Version 2.4.0-1 and now it works again.

Thank you