After upgrade to Snapshot it is not possible to install new bindings

I had openHAB Snapshot running on my Syno and the upgraded to by using the following procedure:

  • backup of complete openHab2 folder incl. userdata
  • uninstall old openHAB spk package
  • install new openHAB spk package
  • made sure openHAB runs
  • stopped openHAB
  • restored userdata folder
  • checked configuration which was as before, everything worked
  • tried to install a new Binding via Paper UI which did not work, status only shows “Installing” but nothing happens
  • everything else seems to work normal
    How can I fix this?

You can’t just copy the whole userdata folder and restore it on a new version of OH. There is a ton of version specific stuff in there.

The automated installers are smart enough where it will upgrade your userdata folder for you so when you copied your old userdata over it messed everything up.

Start by deleting the current userdata contents, forcing a reinstall of OH, and then only restoring the jsondb and persistence folders from your old userdata backup. You may have to reinstall some bindings that way but I don’t know how else to do it.

Ok, my bad. While reading other post I found there is no clear documentation exactly which files or folders have to be restored, thanks for the hint.
I have reinstalled OpenHAB and just copied the jsondb folder back, which worked. The bindings had to be reinstalled. The synology version is a little bit special as there is no clear update process except uninstall and reinstall new package.

Thank you for clarifying this as this again reminds us that a simple upgrade is still not possible which was the case in 1.8.
is there someone that could please make a script for Syno users to upgrade the easy way ?
I’m not the expert but it would make a nice addition as the update script is only compatible with the command unzip which no longer exists on Syno DSM6