After upgrade to OH2.3 zwave binding not working after upgrading

I’ve upgraded today to openhab 2.3 release (openhabian on raspberry pi).
I had snapshot jar in addons directory, and after uninstalling it using karaf and installing it again, the ZWave binding not working.
(I had jar, I deleted it, removed it from karaf and reinstalling the offical zwave binding)
In paper UI I see this error on ZWAVE Stick:
Status: OFFLINE - COMMUNICATION_ERROR Serial Error: Port /dev/ttyACM0 does not exist

And can’t see any zwave node thing.
In Habmin I see all the zwave node things and the controller event looks green.

Zwave log looks good:

28-May-2018 22:35:06.403 [INFO ] [col.serialmessage.SerialApiGetInitDataMessageClass] - NODE 33: Node found
28-May-2018 22:35:06.403 [INFO ] [col.serialmessage.SerialApiGetInitDataMessageClass] - NODE 34: Node found
28-May-2018 22:35:06.404 [INFO ] [col.serialmessage.SerialApiGetInitDataMessageClass] - NODE 35: Node found
28-May-2018 22:35:06.405 [INFO ] [col.serialmessage.SerialApiGetInitDataMessageClass] - NODE 36: Node found
28-May-2018 22:35:06.406 [INFO ] [col.serialmessage.SerialApiGetInitDataMessageClass] - NODE 37: Node found

Are you using more than one usb stick? Ports may have changed after reboot:

Also check via karaf and bundle:list | grep nrjava if your nrjavaserial is present:

openhab> bundle:list | grep nrjava
192 │ Active    │  80 │ 3.12.0.OH              │ nrjavaserial

I’m using only one stick ttyACM0. and have nrjava

$ dmesg -T | grep tty
[Mon May 28 22:59:46 2018] Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbdepth=16 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ea00000 vc_mem.mem_size=0x3f000000 dwc_otg.lpm_enable=0 console=tty1 root=PARTUUID=6a2e76ea-02 rootfstype=ext4 elevator=deadline rootwait
[Mon May 28 22:59:46 2018] console [tty1] enabled
[Mon May 28 22:59:46 2018] 3f201000.serial: ttyAMA0 at MMIO 0x3f201000 (irq = 87, base_baud = 0) is a PL011 rev2
[Mon May 28 22:59:46 2018] 3f215040.serial: ttyS0 at MMIO 0x0 (irq = 220, base_baud = 50000000) is a 16550
[Mon May 28 22:59:48 2018] cdc_acm 1-1.3:1.0: ttyACM0: USB ACM device

Looks good.
Try the usual thing :grinning: :

already tried it… didn’t help :frowning:

Already checked which zwave binding version is running?

bundle:list|grep -i zwave

If the version you intended to use is running, the last idea I have:

physically power down the RPi sudo shutdown -h now and remove power plug, then boot it again (I once had this to do to make it work again …)

236 │ Active │ 80 │ 2.3.0 │ ZWave Binding
tried the shutdown it didn’t help…

another question.
if I choose to clean install openhab again,
Does the zwave nodes will be installed automatic? or I would have to exclude+include them again?

Your zwave network exists in the usb disk. so when you reinstall everything including the z-wave binding, and you run the discovery option, all your nodes will be found. of course you need to create everything again, channels, rules etc so better get a backup before doing so.

Is there a “good” way to upgrade OH2.2 running an older zwave security snapshot binding (mine is from March) to OH2.3 with the zwave security binding in the distro without breaking everything? I’d like to upgrade but am afraid since moving from the release OH2.2 binding to the snapshot required recreating everything…

The inclusion information is stored on your zwave controller, your things and channels are stored in your JsonDB (if you did not manually configure them through text files).
There is almost never the need to exclude or include devices again.
So yes, do a backup and then restore your settings: