Alarm Decoder binding question

I previously used Vera to control my Vista 20P alarm system with a AD2USB device and then with the mios binding I could use it with OpenHAB. Last week when using the Alarm Decoder Webapp I noticed there was a firmware upgrade, so I upgraded my device. Since then my AD2USB is only detecting motion detector activity, it doesn’t detect entrance doors opening anymore. I read the following on the AlarmDecoder website about the new firmware:
“Replaced LRR formate messages with new CID format standardizing alarm reporting across panel types using Contact ID.”.
I am looking at switching over to use the AlarmDecoder binding if that will fix my problem. Will the AlarmDecoder binding work with this new format? Also, is there any plans for a 2.0 version of the Alarm Decoder binding to automatically detect zones? Thanks for any help.

I will check that out. I coded the LRR part of AlarmDecoder Binding. Also can you connect to your AD and checkout the LRR messages? Also paste the out of this command

Also try disabling CRC ConfigBits

AD’s documentation still shows the same format here

Can you open an issue on the alarm decoder git page?

Thanks for the reply Lucky. With the AlarmDecoder Webapp I am able to see messages:
Motion detectors seem normal and they still work for me in Vera.
Wired motion detector: !REL:13,01,00
Wireless motion detector: !RFX:0389988,80
But for entrance doors all I get now are:
[00010001000000000A–],003,[f70200051003000008020000000000],"FAULT 03 GARAGE DOOR "

How do you disable CRC Configbits?
I have been working with AlarmDecoder support. I installed the old firmware back on my device but that didn’t fix it. Maybe something got corrupted on it. They are sending me a new AD2USB.
I’ll report back on my results with the new one.
Yes, I see the documentation is the same. If you go to the firmware page you will see the change.

I didn’t see anything different with their documentation. When I come home later, I’ll try to update the firmware to see what’s going on. FYI I also have a Vista20P, and everything works.

What I’d like to see is your AD config. You can do this by telnetting/Serial to your AD and issuing this command
C then hit enter

And from your logs, it looks like you don’t have the LRR enabled. Otherwise you’d see !LRR Messages

LRR is actually optional. LRR is the actual message sent by the panel to your monitoring company. The radio messages are what’s important in the AlarmDecoder binding.

I also noticed from your first message:

Are you actually using the AlarmDecoder Binding?

No, I am not currently using AlarmDecoder binding. I am trying to figure out if it would fix my problem. According to the guys at AlarmDecoder I need to upgrade my Vera firmware. I don’t really want to do that because the last time I on was on the Vera forums people were saying they were having problems with the upgrade. I haven’t really used the Vera unit directly for a long time. It just does my Z-Wave and my Alarm system. Then with the mios binding I can get that information into OpenHAB. I must have !LRR messages enabled, everything worked fine until I did the AD2USB firmware upgrade.
Here is my AD2USB config:

I see. I thought you were using AlarmDecoder. I suggest you do since you already have a AD2USB. All you have to do is configure your AlarmDecoder Binding to use the USB (COM for Windows, /dev/** for Linux). AD2USB is working fine even on the latest AlarmDecoder firmware.

You upgraded to the the latest firmware and Openhab can still detect entrance doors opening and closing? Since you have the same alarm panel as me could you post your setup: items and rules needed for basic setup. I’m expecting my new AD2USB to come in a few days. Maybe my last one got corrrupted or something when I upgraded the firmware somehow,

I’m playing around with the AlarmDecoder Binding a little bit to see if my motion sensors can work with it now. Having problems with the “connect” line in the config file. My AD2USB is attached to another Raspberry PI whose address is and then its the serial connection of /dev/ttyUSBO . I’ve tried various ways of putting these together but still get "got no such port for"
Do you know what the line should be?

/dev/ttyUSBO has to be a zero… /dev/ttyUSB0
or try lsusb and dmesg commands to see where it is.

If serial is giving you issues, install ser2sock from AlarmDecoder itself. I use ser2sock so I can connect to it anywhere in my network just using putty…

Here’s my config. I am using ser2sock to expose AD on a TCP socket:

# use this line to reach an IP-enabled alarmdecoder (ad2pi) via tcp:

ad2pi is my hostname for my AD. My AD is not connected to my openHAB pi, but running on a dedicated OrangePi ($9 !)

Try issuing these commands to see where the AD is:

dmesg | grep USB

Here’s a sample items file (Im only including 2 items, I have 40+ sensors)

Contact alarmContactZone23GarageDoorDriveway "Garage Door Driveway" (gAlarmContacts,gAlarmAllSensors,gAlarmAllSensorsDownstairs,gAlarmAllDoors,gAlarmAllDoorsAndWindows) {alarmdecoder="RFX:0954588#contact,bitmask=0x10"}
Contact alarmContactZone24MotionDetectorOffice "Motion Detector Office" (gAlarmContacts,gAlarmAllSensors,gAlarmAllSensorsDownstairs,gAlarmAllMotion) {alarmdecoder="RFX:0097360#contact,bitmask=0x80"}

The good thing about AlarmDecoder is that you can use a sensor even if the sensor is NOT enrolled/registered to your Vista20P since AD broadcasts all RF messages

I used the image from alarmdecoder website to install on my rpi. I think the hostname is “alarmdecoder”,
but when I use the following line in the config I get unknown host error message:
In the alarmdecoder webapp when I go to “settings” and then “advance” and then “host” it does say alarmdecoder is the host name also.

Try using the actual IP address instead of “alarmdecoder.” Hostnames, etc depends on how you configured your DHCP also, so to make it simpler for you, just use the IP address.

If you want to use TCP for AlarmDecoder binding, you first need to install ser2sock on your pi.
12800 is the port THAT I configured, so you will need to change that also.

Install ser2sock:

sudo apt-get install git
sudo apt-get install build-essential autotools-dev devscripts
git clone ser2sock
cd ser2sock
sudo cp ser2sock /usr/local/bin/
sudo cp -R etc/ser2sock /etc/

****** Make changes to /etc/ser2sock/ser2sock.conf as needed.******
****** Change your port, etc ******

sudo cp init/ser2sock /etc/init.d/
sudo update-rc.d ser2sock defaults
sudo /etc/init.d/ser2sock start

After the last command, the service should be running.
Connect to that IP address using the port you configured. You should see the messages from AlarmDecoder like this:

Note that the terminal you open is the AD itself. You can issue your commands there as if the terminal is a keypad. So while you’re in the terminal, try PIN1 then Enter (which is Disarm)…


Ok, I finally got the config line right. It ended up being:
I tested it out with one of my motion detectors and it worked. So I should be ok with motion detectors.
However this is all I get from hard wired entrance doors:
[00010001000000000A–],003,[f70200051003000008020000000000],"FAULT 03 GARAGE DOOR "
Is there anything in that line I can use to set up my Item in OpenHAB for that zone?
In a previous post you mentioned that it didn’t look like I had LRR enabled. I think your right. I don’t have my alarm system monitored by any service. Will LRR show the entrance door opening. If so, can you tell me how you have your Vista 20p set up for that. I looked in the manual and I can enable it but it appears you have to pick among various options. Thanks alot for your help!!!

To enable LRR, go to your Vista20P programming mode, then LRR is in *29 menu