Alexa and openHAB in Australia

Has anyone done a successful implementation in Australia? Thinking of buying a few of Amazon Echo devices and just want to make sure that it will work.

As far as I can see the “openHAB” Alexa skill is not available in the AU region… :frowning:


Hi, I’ve been running it for a couple of years now.
First with habridge but now mainly with the Hue Emulation.
For my purposes I found this superior to the skill, although I have also used that.

Given that the hue emulation gives me most of what I want I prefer to keep what is in the cloud to a minimum, so the local nature of the hue emulation is a major plus for me.

Overall I find it works really well with the one main issue being that my name as John sometimes Alexa says can’t find Joan’s Light… and similar things.
I control lights, roller shutters, fans, television, kettle, Roomba and previously my aircon with it, so I am very happy. Just waiting now for a good integration option for my new Daikin AC.

Hope this helps

Thanks John!

Went and bought the Amazon Echo (2nd Gen AU) yesterday. Initial setup of it was flawless, however I am pulling my hair out now trying to integrated with the openHAB.

  • Openhab version 2.2 runs on port 8080
  • Hue Emulation 2.2.0 (discovery web port set to 80 and port forward is setup with iptables 80 ==> 8080
  • one switch was tagged as “Switchable” and I can see it in /api/discovery.xml
{"lights":{"1":{"state":{"on":false,"bri":-1,"hue":0,"sat":0,"xy":[0.0,0.0],"ct":500,"alert":"none","effect":"none","colormode":"ct","reachable":true},"type":"Dimmable Light","name":"Kitchen Switch","modelid":"LWB004","uniqueid":"1","manufacturername":"openHAB","swversion":"66009461","pointsymbol":{"1":"none","2":"none","3":"none","4":"none","5":"none","6":"none","7":"none","8":"none"}}}}
  • Amazon Echo is setup on the same subnet as openhab (
  • UPnP is enabled on the router
  • debug log shows nothing… no attempts from the Echo to pull /api/description.xml or /api/discovery.xml

Any ideas would greatly appreciated :slight_smile:


Hi Alex,

I left the discovery port blank when I set up mine so no need for any port redirection.
Also, do you have pairingEnabled set to true under PaperUI -> Configuration -> Services -> Hue Emulation -> Configure ?


Yes, pairingEnabled=true and I’ve tried both options with port=80 and blank… :frowning:

Could you please post your item definition?

Here it is… Then the item is linked to Thing channel in HABmin…

Switch  TestSwitch1     "Kitchen Switch" [ "Switchable" ]

It looks good to me.
The only other thing I can say is my devices never show up immediately, but I have almost 300 items.
So you may have to wait a little while but it never takes more than a few minutes.

Well… the problem is that Alexa/Echo is not discovering the openhab… there is NOTHING in a hueemulation debug log related to Alexa asking for config via UPnP broadcast

Do you have any firewalling on?

Also UPnP is using UDP, it wasn’t clear when you said you used iptables to redirect port 80 to 8080 which protocol you configured for. I assume it was done locally on the openhab server.

You mentioned earlier that you had UPnP enabled on the router but that would only be for UPnP control of the router itself, nothing really to do with the Echo or Openhab.

No firewalls on the internal LAN. Port redirection was done locally on the openhab server

Hi Alex,

I notice you are already asking the same questions on other discussion threads as well.
I’m afraid I have run out of ideas based on what you have told me so far and the other threads have a lot more info for troubleshooting, so I will leave this thread here as the troubleshooting probably belongs on the other threads.

I’m sorry I couldn’t be of more help but in my environment it just worked.


No problem John. Really appreciate your help and time.