Alexa and Thermostat on Remotec Z-Wave AC Master

Hi all,
I have interfaced the Remotec Z-Wave AC Master.
On openhab’s app it’s works fine.
I have next try with alexa.
This is my items:

Group           ThermostatCP                    "Condizionatore"                                        {alexa="Thermostat"}
Number          CameraTemperatura          "Temperatura [%.1f gradi]"      (ThermostatCP)          {alexa="CurrentTemperature"}
Number          CameraSetPoint             "Scalda fino a [%.1f gradi]"    (ThermostatCP)          {alexa="TargetTemperature"}   
Number          Mode                            "Metti [%s]"                    (ThermostatCP)          {alexa="ThermostatController.thermostatMode" [HEAT=2,OFF=0]}

get temperature of “Condizionatore”
set temperature of “Condizionatore” at…
set “Condizionatore” to off

Doesn’t works:
Turn on “Condizionatore”

How I can solve it?

Unfortunately, you can’t use that utterance to turn on a thermostat device as it conflicts with a standard PowerController capable device. You can turn your heater this way:

Alexa, set Condizionatore to heat

Or, if you only have one thermostat device setup on your Alexa account:

Alexa, turn on the heat

Hi @jeshab, thanks for reply…
It’s works also in another language (for example italian)?

Have you tried? The second utterance may only work in English but the first one should be the same than when requesting your thermostat to be set to off.

Also, another utterance you can use if you only have one thermostat:

Alexa, set the thermostat to heat

According to Google Translate, this translates in Italian to:

Alexa, imposta il termostato su riscaldamento

Based on a quick Google search, it seems that you may need to specify the translated term “mode” in the utterance in Italian and probably in other latin-based languages when requesting for a given device name:

Alexa, imposta il deviceName su modalità riscaldamento

Hi @jeshab, it’s works fine.
Now I understand how alexa works with thermostat…

Great :+1:

Make sure to mark my last reply as the solution.