Alexa endpoint group functions

I’ve tried many iterations of this but have had no success accessing any of the functions except the power by saying “Alexa, turn on dining room stereo”. Any command to access, increase, decrease, or set to on volume or turn on/off mute gets me a response, “Dining room stereo doesn’t support that.” Any help will be appreciated.

Blockquote
Group nuvo_z1 “Dining Room Stereo” {alexa=“Endpoint.Speaker”}

Switch nuvo_z1_power “Power” (nuvo_z1) {channel=“nuvo:amplifier:myamp:zone1#power”, alexa=“PowerController.powerState” [category=“SPEAKER”]}

Switch nuvo_z1_mute “Mute” (nuvo_z1) {channel=“nuvo:amplifier:myamp:zone1#mute”, alexa=“Speaker.muted”}

Dimmer nuvo_z1_volume “Volume [%S]” (nuvo_z1) {channel=“nuvo:amplifier:myamp:zone1#volume”, alexa=“Speaker.volume” [increment=“10”]}

Number nuvo_z1_bass “Bass [%.0f]” (nuvo_z1) {channel=“nuvo:amplifier:myamp:zone1#bass”, alexa=“EqualizerController.bands:bass” [range="-18:18"]}

Blockquote

The item definition looks good to me. Can you please share the utterances you used to command the other capabilities?

I tried “Alexa, mute dining room stereo.”, “Alexa, set dining room stereo to mute”, “Alexa, turn on dining room stereo mute.”

The response is the same each time, “Dining room stereo doesn’t support that”.

After changing the volume label to “Volume”. That seems to work at least.

I also tried this with no success. I thought I copied the method correctly from one of your previous replies.

Blockquote
Number nuvo_z1_source “Source” (nuvo_z1) {channel=“nuvo:amplifier:myamp:zone1#source”, alexa=“ModeController.mode” [friendlyNames=“source”, supportedModes=“1=Sonos,2=Spotify”]}
Blockquote

The item label only comes into play for items part of a group endpoint modeled as Mode, Range or Toggle controllers. So for your volume item, it is not a factor.

Are you triggering discovery request on the Alexa side whenever you made these configuration changes? Also check for potential item definition errors in the OH server logs.

Thanks for the help. As I was continually changing my items file, I didn’t always trigger an Alexa discovery event and must have been zigging while the file was zagging and never got it to work correctly. I now have all the commands working correctly.

1 Like