Alexa, myopenhab & OH2.5

Hi all,

I’m getting crazy :upside_down_face:
after googeling and browsing the community, I still can’t get my OH2.5 connected with Alexa.
openHAB Cloud connector is setup and working, Sitemaps in the Android App are working well.
openHAB Cloud Status is ONLINE
Amazon account is registered with, application is shown in my account / applications
Tag is addend via REST, result checked with HABmin, looks great.
REST request via shows all Tags, so communication between cloud and server seems to work.

Already using V3 syntax: {alexa=“PowerController.powerState” [category=“SMARTPLUG”]

But still when searching for devices I only get the answer no devices found :frowning:

Any idea what’s wrong?


Try installing the Amazon Control binding

Then take one of your items and use the v2 tagging [ “Lighting” ] and make sure that you have the openhab skill added via the Alexa app then try to discover the device.

I have not tried the V3 syntax yet so no advice on that but as mentioned try one device with V2 tagging. Verify that is working then move to V3 and maybe that will narrow down where the issue is.

Hi H102,

tried your tip, but no result. Not with V2 and also not with V3 syntax.


353 │ Active │  80 │ 2.5.0 │ openHAB Add-ons :: Bundles :: IO :: openHAB Cloud Connector
354 │ Active │  80 │ 2.5.0   │ openHAB Add-ons :: Bundles :: Amazon Echo Control Binding

All Alexa devices are visble in openHAB, but my items are not reachable by Alexa, (no devices found)

In the Alexa app when you click on discover new devices?

same result with

  • voice command
  • Alexa Webpage
  • Alexa App

-> no new devices

Uninstall the OH skill in Alexa app then reinstall.

@Mike-Mayer I played hell years ago getting this to work the first time also. That was years ago, still not sure why it never worked.

My advice if you are confident tags are correct. Shutdown openHAB, clean cache, restart and try again discovering tomorrow.

I know this is not good advice but I have had many things that just had to sit. No explanation of the symptom but coming back the next day worked.

reinstalled three times with same results. Will try to clear the cache.

@Mike-Mayer if you have a device to install the google app on Android or iOS you could install google home app. Use the tag on one switch [ “Lighting”] see if you can discover with google.

This proves your my openHAB is functioning. If google discovers this one then you could try alexa.

@Thedannymullen: Any pointers for google? I just started with google (only have one google mini) and it does not find any of my devices but Alexa works with everything. :thinking:

No real pointers just make sure you have skill installed and proper tags.

I had issues getting started also, really not sure what the problem was. But once it worked it has kept working. Main thing I would say is if it does not work wait a day just to be sure. Maybe restart just to be sure all tags picked up.

Have you tried an item file instead of the REST? I had issues when I incorrectly entered something via REST, but once I did it in the item file I had no problems.

Hey QuagmireMan,
the dedicated item file works! Thank you for the hint! now i can check the difference from the REST



The alexa tags are not visible…
Switch alexa_bd2 "Spiegelschrank" {alexa="PowerController.powerState" [category="SWITCH"]}

1 Like

Hi, i’m having the same problem. Can you show me your item file ?

What type of item are you trying to add the tags to?

Dimmer LivingRM_Dimmer "Living Room Light" {alexa="PowerController.powerState,BrightnessController.brightness"}

‘fake’ switch to start a rule.

This is one from the documentation.

Switch DeviceSwitch "Device Switch" {alexa="Switchable"}