Alexa Skill find no new items

Tags: #<Tag:0x00007f7465e52258> #<Tag:0x00007f7465e52168> #<Tag:0x00007f7465e520a0>

Hi openHAB community,

I fight since a few days with an issue that my new added items are not find by alexa. I use the alexa skill. All my items which are found already work perfectly (54 items).
Now I integrated a Roborock Vacuum Cleaner over MQTT. The configured items work well but if I add the alexa metadata labels there are not founf by the alexa app.

I also notice that, if I delete an old item its not found again.

What I tried:

  • Reboot
  • Update 2.4 installaion on my openhabianpi
  • check the log… No error while item discovery
  • disconnect skill and connect again
  • delete all skills in openHAB cloud and connect again

Nothing soleve the problem… Any idea where to search?

Thanks for your help!

P.S I will post my roborock integration based on valetudo … I hope anybody is interessted… I love it… Would only be nice to trigger cleaning by Alexa :slight_smile:

You should follow the troubleshooting guide. If necessary, stagger the discovery process by adding a couple devices at a time to isolate the culprit. Also, if you remove all the new items you added, is the old item you deleted discovered again?

Hi Jeremy, very good hint. I double checked, but all the hints which are given in the troubleshooting guide I tried already.

When I start the discovery no new items are added, but the existing ones are working fine. If I delete a working item in the Alexa app and start discovery again, its also not found anymore…
Nothing in the openhab log which can be linked to the problem.

What about if you delete all the items you added prior to experiencing this issue? Also, are you are able to control your existing devices?

Yes, as I wrote before: I can control the existing items perfectly since a long time. Thats the reason why I don’t want to delete them. If someone tell me that there is a known issue with the alexa skill that I need to delete all devices before I can add new ones I would give it a try… But I don’t find such an issue here…

Have you tried cleaning the cache?

sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo systemctl start openhab2 or you may need to reboot sudo reboot

Also make sure you don’t have simple mode turned on in PaperUI if using files as this can create duplicate items/issues.

What version of Amazon binding are you using? I’m on OH 2.4 stable with amazon control binding version 2.4.0.201812011454.jar that I manually placed in ‘/usr/share/openhab2/addons’. Not sure what beta version this is but if I had to guess it’s either 7 or 8.

Hi h102,

thanks for the hint. I did the cache clear… But after that my system did not came up properly.

  • paper ui does only work sporadically
  • amazon echo service does not come up at all
  • I see my devices come up in the log but all rules react super slow (take minutes to react on a switch)
  • No openhab web service :frowning:
    -…

Not acceptable. I fall back to my old image now.

My system is openhab 2.4 latest stable version. I did not add any addon in the addon folder.

My feeling is: I have so many services, rules, items, addons, that my raspi pi3 is totally unable to boot with empty cache.

I will investigate further tomorrow…

There are no known issue with the Alexa skill. Basically, if tweaking the items doesn’t fix your problem, then it’s a server availability issue. You have to check that you can access the REST API service via the myopenHAB cloud service.

Also, since you are using 2.4, keep in mind there is a know issue when using the Amazon Echo Control binding, released in that version, that breaks the REST API service.

1 Like

Hi Jeremy!!

thanks a lot! That an important info.
I am using the old Alexa skill. I will try the 2.5 version as soon I get home and give feed back, if it solves my problem.

OK, I tried yesterday what you proposed. Now is the 2.5 M2 binding running.
But I still can’t discover my new items. Its a very simple config:

Switch Valetudo_Start_Clean "Starte Staubsauger" { alexa="Switchable" }

I don’t see the problem. Also the devices which are deleted from Alexa are not coming back

I changed from version 2 syntax to version 3 syntax last week and had no problems (Snapshot #1665 which is basically Milestone 3)
Did you follow the recommendation to check the server availability?
https://www.openhab.org/docs/ecosystem/alexa/#server-not-accessible

To resolve this error, make sure that your server is running, your openHAB cloud service is configured with mode set to “Notifications & Remote Access”, and showing online under your myopenHAB account.

@sihui
thanks for the hint but I switched to version 3 syntax longer time ago.
OpenHAB cloud is also configured to the right mode.

Does anybody know if there is a limit in v3 of maximum exposed items to Alexa? I have currently 54 devices active in Alexa.

I am not sure about a limitation but you should be fine with your number of devices. I have about 30 devices and 40 scenes without any problem.

What happens when you click on this link?

Hey, first of all, myopenhab.org is running with your system. If you control your items over myopenhab.org its great, with App for example. After that, check if configuration–services-io- openhab cloud- activate items for apps. Than, test the cloud again. Now your items, its wrong you have to change: Look to the picture. One reboot, discover with alexa and the openhab skill, and normally it works.
_20191102_085906

You use the metadata conf, or you can test it to delete your space like this {alexa=“Switchable”}

The v2 style will be translate in v3… Thank you for that🤓

@Bjorn_Hamburg: Thank you that you repeated this. As I wrote before I checked all this already.
Neither V2, V3 syntax works for my new added titems. They are not added to Alexa. All items which I see in Alexa already are working fine (54!).

How can I check that the 2.5 M2 alexa control binding is running? May be the problem is still there.
In PaperUI is the binding uninstalled and the 2.5 binding is in the addon folder. My alexas can be controlled. But can I be sure that the 2.5 binding and not the 2.4 binding is running?

Ok, Do you check v2 Syntax? Its also a possibility at alexa app. Settings–alexa privacy- Smarthome things delete… If you check this, than avs or the server delete the logs. Its very complicated to see the logs of avs. Best regards

There you can find your binding, sorry forgot it :blush:

https://www.openhab.org/docs/administration/bundles.html

You can check the binding login web page.

No. Binding versions are synced with server releases unless you are using an external binding jar via the addons folder.

Have you tried that link?

@jeshab
OK. I did not know that JSON link. Great!
It shows nearly 375 entries. And also the ones which I not see in Alexa:

For example the one from above:

  {
    "link": "https://myopenhab.org/rest/items/Valetudo_Start_Clean",
    "state": "NULL",
    "metadata": {
      "alexa": {
        "value": "Switchable"
      }
    },
    "editable": false,
    "type": "Switch",
    "name": "Valetudo_Start_Clean",
    "label": "Starte Staubsauger",
    "tags": [],
    "groupNames": []
  },

Looks not wrong or? But can not be found by Alexa…

That item definition object you provided looks good. How long would you say the response time from that link takes? Is the JSON object returned truncated?

Also, if you provide me with the exact time you triggered a discovery request and the region you are located, I could try to see if your request is generating any errors in the skill logs.

@jeshab you are my Hero :slight_smile:

The JSON link opens fast. I don’t see a delay.
I triggered another search today (3.11.2019) at 17:16:05: “No new devices found”.

Meanwhile I connected also Google Home to openHab. I see the missing devices there and can control them (I added also V2 syntax for that).
If your log does not help I think I will reset the openHab connection to Alexa completely and try to connect it new.

Is the JSON object returned truncated?

I don’t see something truncated also no error message.

Last entry:

  {
    "link": "https://myopenhab.org/rest/items/Echo_Living_Room_MediaProgress",
    "state": "UNDEF",
    "stateDescription": {
      "readOnly": false,
      "options": []
    },
    "metadata": {
      "channel": {
        "value": "amazonechocontrol:echo:XXXXXXXXXXXXXXXXXXXXXXXXXXX:mediaProgress"
      }
    },
    "editable": false,
    "type": "Dimmer",
    "name": "Echo_Living_Room_MediaProgress",
    "label": "Media progress",
    "tags": [],
    "groupNames": [
      "Alexa_Living_Room"
    ]
  }
]

Is the skill developed by you? If yes, thanks for the great works!! Don’t understand it wrong if I ask for fixing this problem… In general its a great skill!!